Support » Plugin: Read More Without Refresh » upgraded plugin now it doesn’t work

  • Resolved bwickert

    (@bwickert)


    I upgraded the plugin today and now it doesn’t work. Was the shortcode also changed from [read more=”Read more” less=”Read less”] to [read more]? I have over 100 instances of this throughout the site.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author gkouvousisg

    (@gkouvousisg)

    You could not define the text in the previous version aswell.
    [read more][/read] was always working.

    Can you be more specific please? ‘Doesnt work’ is not something helpful, unfortunately.

    Thank you for getting back to me so promptly. Luckily I still had an older version of the software and uploaded it and now it works again. By “Doesn’t work” I mean the function of expanding the text didn’t work anymore after I upgraded. It literally showed the shortcodes of [read more] and [/read less]. WP version 4.9.8 There must be a glitch in the upgrade.

    Plugin Author gkouvousisg

    (@gkouvousisg)

    It should work backwards aswell.
    My demo is running on the latest version but I’ve run 3.0.1 version of Read More Without Refresh just fine before I do update to WordPress 5.0.

    I upgraded to version 3.1
    -The function of expanding the text doesnot work anymore after I upgraded. It literally showed the shortcodes
    – On the page I have a few read more buttons, only the first shows

    https://www.watervuur.nl/beauty-centrum-reward-beauty/

    Marj Esch

    (@echelonwebdesign)

    I’m having the same issue with version 3.1. Anything inside the [read more] [/read] shortcode doesn’t display. I don’t see the shortcodes and there’s no link to read more. I rolled back to a previous version that I luckily had saved (version 2.3), and it works fine.

    Marj Esch

    (@echelonwebdesign)

    So I updated the plugin to 3.1 again (knowing I could roll back if needed), and I still couldn’t see a read more link. When I inspected the code I saw the hyperlink itself, but nothing between the tags. I discovered the settings page (didn’t exist in 2.3) and did nothing besides click on save changes. Now it works fine.

    • This reply was modified 11 months, 1 week ago by Marj Esch.

    OK. I also had the settings page missing. So I reinstalled the plugin.
    Now it is working. Except the button text is always displaying what is in the settings.

    The latest updates deactivated the plugin

    Activating the plugin still does not make things work

    You have to go to the new settings “RMWP Settings” (displayed in left admin menu below “Settings” – but not in “Settings”)

    then click Save Changes

    • This reply was modified 11 months, 1 week ago by NightL.

    Neither v3.0 nor v3.1 work correctly for me – in fact they are automatically de-activated on my site, with the following report on the Installed Plugins page:

    “The plugin read-more-without-refresh/index.php has been deactivated due to an error: The plugin does not have a valid header.”

    I have WP 5.01 but with the Classic Editor (latest version).

    I re-installed an earlier version of RMWR from another site and everything is back to normal.

    Plugin Author gkouvousisg

    (@gkouvousisg)

    I can see my demo functioning fine under latest version of WordPress and plugin’s one.

    Also, there are side mentions that upgrading to 3.1, solved any compatibility issues with Gutenberg.

    Thus, i want to ask you to upgrade to 3.1, set any possible settings in the menu of the plugin and verify the same.

    For some reason now I can get the plugin v3.1 to activate, but the trigger text is not visible, therefore the option to read more doesn’t exist for the user. So once again I am going to have to copy an earlier version of the plugin into my site.

    What menu settings might make a difference?

    Plugin Author gkouvousisg

    (@gkouvousisg)

    Whats the specific error that is shown upon activation?

    I described the error text earlier, as follows:

    “The plugin read-more-without-refresh/index.php has been deactivated due to an error: The plugin does not have a valid header.”

    This was with v3.0 or (seemingly) v3.1

    Now v3.1 seems to activate OK but it hides the trigger text.

    Reinstalling v2.3 solves all.

    P.S. – the apparent inconsistency could well be due to caching.

    Plugin Author gkouvousisg

    (@gkouvousisg)

    Its for sure something related to your installation and your third party plugins, elsewise, it would be also verified locally.

    I advise clearing all caches, deactivating all plugins and enabling my plugin first, then enabling one by one, all other plugins, as a step of troubleshooting this issue.

    • This reply was modified 11 months, 1 week ago by gkouvousisg.
Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘upgraded plugin now it doesn’t work’ is closed to new replies.