Upgraded, now it says I haven't installed WP. (25 posts)

  1. joker619
    Posted 10 years ago #

    I upgraded from 1.5.2 to 2.0.1. After I ran upgrade.php, I click on "Have fun . ." and it takes me back to the homepage. All that's there now is "It doesn't look like you've installed WP yet. Try running install.php." I do not know why this happened. The only extra plugin I had running was lazyest-gallery and it's suposedly 2.0.1 compliant. Having 0 installation issues in the past, I did not back up the original DB files. So I have three questions:

    1. Does anyone know what may fix the problem?
    2. Where Can I find the old 1.5.2 zip file
    3. I'm not a DB expert, so if i need to revert back to 1.5.2, will i need to cleanup any changes in the db? What feilds?

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    The DB changes have been made so putting 1.5.2 back will cause errors.



    Then put 1.5.2 in.
    BEFORE YOU DO THIS, backup the existing data.

    I have posted the problem to the hackers list. I hope one of them answers.....

  3. joker619
    Posted 10 years ago #

    Wow, thanks for the quick response! I performed the steps above and still no go. I'm left with 1.5.2 in my webroot and whatever was the end result of the downgrade script. I also made a backup of the db before running the script so I still have a 2.0.1 copy of that. Any additional advise would be greatly appreciated. Thanks.

  4. ringmaster
    Posted 10 years ago #

    It would be useful to know what, if anything, this query returns when executed directly in mysql or via phpMyAdmin:

    SELECT option_value FROM wp_options WHERE option_name = 'siteurl'

    Note that you should replace "wp_options" with the table with your database prefix, if it's something other than "wp_".

    You can also try looking at wp-settings.php and commenting this line:


    That will show any errors that take place when WordPress tries to run that query. The query itself is the one that detects whether the WordPress database is actually installed.

    Assuming that query actually runs and returns a value from phpMyAdmin (it must do so if WordPress is to believe that the database is installed), my next step would be to make sure the correct database is selected in the wp-config.php, and not by eyeing the values in wp-config.php, but by adding this code just after the hide_errors() line above:

    echo "<pre>".$wpdb->options."n".print_r($wpdb->get_results("SELECT * FROM {$wpdb->options}"),1)."</pre>";die();

    This will output everything in the wp_options table so that you can verify for yourself that the 'siteurl' option is actually not set, and that the table name (the very first line in the output) is what it is supposed to be.

    From there, more investigation might be required.

  5. joker619
    Posted 10 years ago #

    siteurl was empty so I changed it to the correct url. I made the code changes as described and placed the results here: http://www.joker619.com/output.htm

    The end result is still the same with the siteurl filled out. In ringmasters post, the url is enclosed in tics " ' ". I assume that these are not needed in the siteurl value. . .

  6. Mark (podz)
    Support Maven
    Posted 10 years ago #

    joker619 - are you still having a problem with this ?

  7. joker619
    Posted 10 years ago #

    Yes. I admit I have not done more than what was posted so far. Been really busy. But yeah, the current status is the same. Thanks.

  8. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Before I throw this again at the hackers list, can you tell us

    Your host
    The php version
    The mysql version
    If you are on a windows or linux server

    And if you could do a phpinfo that too would be very helpful.

    In notepad, write this:
    <?php phpinfo(); ?>
    Save it as info.php
    Upload it to your website, then visit the script in your browser
    There should be lots of information there which will be impossible to copy/paste so a direct link would be great.

    The more information we can give the coders, the better chance we have of discovering the cause and cure.

  9. joker619
    Posted 10 years ago #

    My host: My own server
    PHP version: 4.4.1
    MySQL version: 4.0.16
    Windows 2003 Server / IIS 6.0.


    All of this configuration was working perfectly prior to the upgrade to 2.0 so I do not believe that it's a problem with the PHP/MySQL combo or any of that. Whatever changes the 2.0 script made broke the blog.

  10. Mark (podz)
    Support Maven
    Posted 10 years ago #

    I've posted this information to the hackers list again.
    The conversation can be followed in this thread:

  11. ringmaster
    Posted 10 years ago #

    After this line in your wp-settings.php:

    $db_check = $wpdb->get_var("SELECT option_value FROM $wpdb->options WHERE option_name = 'siteurl'");

    Insert this line:

    die($db_check.':'.strstr($_SERVER['PHP_SELF'], 'install.php').':'.defined('WP_INSTALLING'));

    And tell us what you see when you run it so that we can figure out why that section of code (the one that says you still need to install) is running.

    [Note to devs: This line is yucky:

    if ( !$db_check && (!strstr($_SERVER['PHP_SELF'], 'install.php') && !defined('WP_INSTALLING')) ) {

    Let's see what DeMorgan has to say about it...

    !A & (!B & !C)
    !A & !(B | C)
    !(A | B | C)

    So if I did that right, then the line is:

    if(!($db_check || strstr($_SERVER['PHP_SELF'], 'install.php') || defined('WP_INSTALLING'))) {


  12. joker619
    Posted 10 years ago #

    I do not have such a line in the wp-settings.php file.

  13. Mark (podz)
    Support Maven
    Posted 10 years ago #

    In 2.0.1 I make that line 121.

    It's a few lines below the comment:
    // To disable persistant caching, add the below line to your wp-config.php file, uncommented of course.
    // define('DISABLE_CACHE', true);

  14. joker619
    Posted 10 years ago #

    I have 1.5.2 installed, not 2.0.1. Are you guys trying to help me with 1.5.2 or 2.0.1?

  15. Mark (podz)
    Support Maven
    Posted 10 years ago #


    Hmm... so..
    You had a working 1.5.2 blog
    You upgraded to 2.0.1 and you get a 'not installed' error
    You run the downgrade script
    You upload the 1.5.2 files
    And you still get the 'not installed' error ?

    Is the above absolutely correct in all detail ? if not, can you list it please ?

    You have not changed any information in w-config.php at all ?

    I have no idea if this would be offered or happen, but would you be prepared to allow someone access to your server for this ?

  16. joker619
    Posted 10 years ago #

    That is correct. wp-config.php was not altered by me in any way. Giving someone access to my server is not out of the question, but I would like to avoid it if possible. I have placed a lot of info about the setup in these two locations:


    Once again, thank you guys for your assistance.

  17. ringmaster
    Posted 10 years ago #

    Ok, so after this line in your wp-settings.php:


    Insert this line:

    die(update_user_cache() .':'. strstr($_SERVER['PHP_SELF'], 'install.php') .':'. defined('WP_INSTALLING'));

    Report back.

  18. joker619
    Posted 10 years ago #

    All that shows up now is "::" as you can see here http://www.joker619.com

  19. masquerade
    Posted 10 years ago #

    The problem is that your blog does not have any users that have a level greater than 0. If WordPress detects this, it claims you haven't installed WordPress. The solution is to manually go into your database and change one of your users back to level 10 (If you have phpmyadmin, that would be ideal).

    I'm not sure why or how this problem occurs, the downgrader tries to do this for you, but for some reason, for me, and you apparently, it fails on Windows. Don't know why or how, but it does.

  20. joker619
    Posted 10 years ago #

    That was it. Thank all of you very much. I've had paid support that wasn't as efficient as this forum. Way to go!

  21. MichaelH
    Posted 10 years ago #

  22. pgray007
    Posted 10 years ago #


    I am having the same problem (minus the downgrade back to 1.5.2). I follwed the upgrade steps on the codex, and get the "WP is not installed" message.

    I've checked the following:

    * wp_config.php is OK
    * commented the "hide_errors" line; nothing appears other than the "not installed" message
    * put in ringmasters "die..." line. I get "::" returned
    * checked my patandmeg_user_meta table and my admin user has a value of 10.

    I am stuck. Any suggestions??? I moved my working 1.5.2 blog to a test server and all was working, then immediately after the 2.0 upgrade my "not installed" problem started.

  23. MichaelH
    Posted 10 years ago #

    For people needing to make sure there is a user with admin rights see this:


    This is for 2.0 and higher, not 1.5.2

  24. pgray007
    Posted 10 years ago #


    Thanks for the script, but no dice. When I try to execute that script I continue to get the dreaded:

    It doesn't look like you've installed WP yet. Try running install.php.

    This is after a "clean slate" install on a new server. I copied over all my 1.5.2 files, restored the 1.5.2 database on the new server, and validated that everything works. I then deleted the files suggested in the upgrade instructions, ran the upgrade script, and was bamboozled.

    Thanks for any more suggestions! I am stuck!

  25. pgray007
    Posted 10 years ago #

    ANyone have any ideas? I'm completely stuck at this point!

    Help! (please)

Topic Closed

This topic has been closed to new replies.

About this Topic