Support » Networking WordPress » Upgraded install to multisite, now post thumbnails broken.

  • I upgraded my web site to a multisite network, and shortly after noticed that post thumbnails on my custom post types stopped working.

    I’ve got a bunch of custom post types (like Movie) with thumbnails. I define them in my theme’s function.php file, in a function run when the ‘init’ action fires. (I also tried pulling it out of ‘init’ and running it immediately when the theme is loaded, but that results in the same thing.)

    Before upgrading to multisite, it worked great. My movies had thumbnails. After upgrading, the ‘thumbnail’ edit panel is now gone from the edit view. Thumbnails previously defined are still used, so in the front end that part still works. But in the admin panel, the ability to add or change them is gone. The Post Thumbnail box is gone from the Edit Post page, and there’s no “Use as thumbnail” button in a post’s gallery anymore.

    And just to cover the obvious, yes I do call add_theme_support( 'post-thumbnails' ), and the register_post_type call includes 'supports' => array('thumbnail'). This same exact code worked perfectly before switching to multisite. I also disabled every single plugin the site uses to check if there’s a compatibility problem there, still nothing.

    Running WordPress 3.1.2, though did the update to Multisite a couple of versions ago. Spent that time trying to figure this problem out to no avail.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Check the “screen options” tab in the edit window.

    Also, go to the Network Admin -> Settings page and make sure you’ve allowed image uploading. Not checking the Image box specifically will hide things this “featured images”. 😉

    I already did check “screen options,” it’s not there. Image uploading was disabled turns out (thanks for the tip!), but enabling it did not cause the missing featured image controls to return. They’re still missing, and still not available under screen options.

    (I tried under both the Administrator user and an Editor-level account. Ditto for both.)

    I’m also having an issue where custom thumbnail sizes won’t show up in WP Multisite

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Dan – start a new thread with specifics please.

    I’m having the same problem as I try to migrate from a single-site to multisite setup. I decided to track down the function that actually writes the “Featured Image” widget into an edit post page.

    I started by hunting through my wordpress installation for the string “Remove featured image” (that’s the text of the link that shows up at the bottom of the widget when you have already added a featured image). That text appears in wp-admin\includes\post.php, in a function called “_wp_post_thumbnail_html()”. I did a search for _wp_post_thumbnail_html, and it gets called in wp-admin\includes\meta-boxes.php in a function called post_thumbnail_meta_box(). So far neither of these functions appeared to do anything out of the ordinary. I couldn’t see any conditional logic that would prevent the Featured Image widget from appearing.

    So I did a search for post_thumbnail_meta_box. That function gets called in wp-admin\edit-form-advanced.php…or at least SOMETIMES it gets called. There are a number of conditions that must return true for the function to get called at all. Here’s the snippet that does it:

    if ( current_theme_supports( 'post-thumbnails', $post_type ) && post_type_supports( $post_type, 'thumbnail' )
    && ( ! is_multisite() || ( ( $mu_media_buttons = get_site_option( 'mu_media_buttons', array() ) ) && ! empty( $mu_media_buttons['image'] ) ) ) )
    add_meta_box('postimagediv', __('Featured Image'), 'post_thumbnail_meta_box', $post_type, 'side', 'low');

    See that nasty little ! is_multisite() in there? Looks like they have purposefully disabled the display of the Featured Image widget in multisite installations. There must be some deeper conflict or bug that it’s causing.

    I don’t know what their reasons are, but I think I’m going to try to figure out what they’re testing with that $mu_media_buttons variable. Maybe there is some option in multisite that lets you see your featured image. If I find anything, I’ll post it.

    INCIDENTALLY, you can still add a featured image to a post in your multisite installation, even thought the Featured Image widget won’t show. At the top of an Edit Post page, under the title but above the content area, there is an “Upload/Insert” area with an icon that looks like a 6-pointed star (it’s the “Add Media” button). You can click on that, and either upload a new image or view one in your gallery or whatever you would do if you were just adding it to the post content area. When you get to the screen that has a button that says “Insert into Post,” you’ll find that there is a text link next to it that says “Use as featured image.” You can click that, and the image will become the featured image for the post.

    You won’t be able to see what featured image it is when you come back to the Edit Post page, but at least you can still attach the image to the post as a featured image and your site visitors will see it.

    Hope that’s somewhat helpful.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    gurustump – You too need a new post.

    Featured images works just fine in MultiSite. I use it daily.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Upgraded install to multisite, now post thumbnails broken.’ is closed to new replies.