WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Upgraded — but quotes in posts/titles all slashed/escaped?!?

[Resolved] Upgraded — but quotes in posts/titles all slashed/escaped?!?

  • I’m pretty sure I went through all the upgrade steps, wondering if I missed one along the way.

    I’ve moved my (local) content from 1.0a => 2.0.1, and along the way I think post formatting changed to how quotes were escaped/slashed in the database. Well, now I’m seeing all the slashes in the output content. Could be my fault, somewhere, I suppose.

    Anyone have a clue?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Okay, in looking through the upgrade_functions scripts, there is definitely one which does some kind of stripping of escaped quotes and such… maybe I somehow missed a step, but I know I ran upgrade.php.

    Has anyone upgraded from 1.0-era to 2.0 >directly< (the upgrade functions LOOK like they should be able to run all the upgrade steps in order)?

    I will have to start with my db at 1.0-rev, and do whatever upgrade process hopefully ONCE. My theme and custom plugins are already migrated to 2.0-rev, so there’s no turning back.. 😉

    -d

    If you’re at 1.0, you’ll have to go first to 1.2, then to 1.5.2 before upgrading to 2.0. You probably know where to get the old versions, but just for someone who may be searching, the old versions are available from http://static.wordpress.org/archives.

    Actually, no, I don’t. 😉

    My ORIGINAL process here locally was exactly that, to a 1.2 rev, then 1.5 rev, then 2. That is what somehow left me with messed up content, missing a stage or two somewhere.

    My NEW process was to shift my 1.0a DB over from my old site to my new domain, upload my new 2.0 site files, and run upgrade. Content all looks perfect now, everything is functioning fine. I did (do) have problems with some of the rewrite stuff (the get-apache-modules function apparently doesn’t exist on my site5 server, but I commented out that check and everything works fine now).

    So, at this point, problem solved. Now if only the forums had decent SEARCH capabilities, people might find this as a resource. 😉 😉

    -d

    Hmm. Interesting that it worked for you. Well, the search function will be dead forever looks like at this point, I’ll just have to run a perm bookmark for this topic.

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Upgraded — but quotes in posts/titles all slashed/escaped?!?’ is closed to new replies.