Support » Fixing WordPress » Upgraded a plugin, page won’t update

  • On my blog MomReviews, my plugins page showed that the Comment Luv plugin had a new version and needed upgrading. So I downloaded it, uploaded it to the plugins folder, deleted the old version of the plugin, went back to the site and refreshed the page, and it still shows the old plugin version and says it needs upgrading.

    I tried clearing the cache and also logging out and back in. I can’t figure out why the old version of the plugin still shows even though I deleted it. What am I missing?

Viewing 3 replies - 1 through 3 (of 3 total)
  • whooami



    youre missing doing things in the right order.

    download new plugin
    deactivate old plugin.
    remove old plugin
    upload new plugin
    activate new plugin

    so now, you deactivate the plugin, and assuming that the new one is the one inside the plugins dir. you activate the new one.

    You cant assume that plugins change so little that they dont require some sort of RE-activation once a new version has been uploaded.

    .. and since you prolly wont return to that other thread:

    Lorax-I’m glad it’s not just me. I ended up going back to WP 2.2 for now.

    you’ll regret that decision if and when your install is hacked.

    thats NOT a solution to anything.

    Whooami, thanks for the reply. I should have said in my original question that I did go back and activate the plugin, but it still shows version .997 as the active version, even though I deleted it with FTP and uploaded the new .999 version. I’m trying to figure out why version .999 isn’t the one showing on the plugins page. Does that make sense?

    Also, if you have any suggestions as to what I can do about the upgrade to 2.3.2 causing my blog to lose all of it’s categories, I’d love the help. I did not understand the answer I got on my post here, which was to drop the tables related to WP, check and restore them, and do the upgrade again. I tried asking what “drop the tables” meant, and I wish I did understand it, but I don’t. Can you help?




    if you are sure that you have the .999 version uploaded, and youve activated it — I, unfortunately, dont have a clue.

    MichaelH did provide some further information in that other thread though, that might help you regarding the category issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Upgraded a plugin, page won’t update’ is closed to new replies.