Support » Installing WordPress » upgrade woes – editor,images,widgets

  • Resolved Chuckmeister


    I upgraded my WP installation from 2.1.? to 2.2.2
    Since the upgrade I am unable to use the editor when writing a post or page. All the editor image tags are gone and also when trying to edit or write a post, to add an image, the add image button doesn’t work. Nor does it work if I write in a direct path into the post. It saves the text (Image code) but it doesn’t reproduce onto the actual published post/page.
    I also have a few widget problems. I have a recent post widget whereby I changed the list to show 50, instead of 10 of the recent posts. Although I have changed my code it doesn’t seem to reflect on the wordpress site.
    I also have lost my RSS feed. It gives me an error of…

    XML Parsing Error: xml declaration not at start of external entity
    Line Number 1, Column 3:

    I have spent all day trying to correct any of the issues but with no joy.
    I have gone through my wp-config and functions.php as I read that there can be excess code or line spaces at the beginning and end of the files. Both appear to be correct.
    I’ve added different wysiwyg plugin’s hoping that it may correct some issue or another.
    I’ve gone through half the files and themes and in fact plugin’s/widgets to see if I can spot anything out of the ordinary.
    I have had a look at my htaccess and that appears to make no difference either. I have a domain redirection in it but whether I leave it there or not makes no difference.
    I have also deactivated plugin’s to count that idea out.
    These are just some of the things I have tried (amongst others)and I have run out of options and ideas.
    Has anyone any suggestions on any solid links that can help for any of the issues or any idea’s of solutions to any of them.
    I can live with most of them but not being able to add images is a real pain…

    so basically

    No RSS with the above error code
    No editor
    No way of adding images (broken button)
    Small widget errors that worked on my old install but not this one (They are all up to date)

    I don’t know if my link is useful to anyone or not but its

    Thank you in advance for any idea’s 🙂


Viewing 7 replies - 1 through 7 (of 7 total)
  • Just a small update… I have solved the TinyMC editor issue by going into ‘my profile’ and un-checking the tickbox for ‘use visual editor’
    I now have my editor back and can also add images into posts 🙂

    Now onto the rss problem again…

    Regarding the RSS issue:

    Somewhere, there’s a file that has a space (or two) before the file’s opening <?php or after the closing ?>

    Odds are, it is either your wp-config.php or a plugin. I think if you find that rogue space and squash it, you’ll be back on track.

    Thanks very much, HandySolo 🙂

    I just went through all my widgets and several of them had a single space trailing the ?>

    Both very simple problems to workaround once its known.

    Thanks again

    Chuck 🙂

    Feed looks good now. Good deal.

    One more note for people that are having difficulties with the visual editor. After turning off the visual editor (above), I have re-checked the ‘use visual editor’ and it now works again.

    Hello Chuckmeister,

    I have same problem like you, only button more, toggle check, and help that display on my TinyMCE editor.

    I do your tutorial above, but the others button still doesn’t display. Any body help me please ? Thanks

    Is getting rid of the rogue space in wp-config.php supposed to fix the image problem as well? Because I did that…and it didn’t. I still have the image problem, although my RSS is fixed now… Please advise. I can’t believe more people aren’t having this problem. I upgraded through Bluehost. Could that have anything to do with it?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘upgrade woes – editor,images,widgets’ is closed to new replies.