WordPress.org

Ready to get started?Download WordPress

Forums

Pods - Custom Content Types and Fields
[resolved] Upgrade Wizard not appearing (6 posts)

  1. pintofmilk
    Member
    Posted 10 months ago #

    My site is running the very old Pods 1.14.4 - I need to upgrade!

    I just updated my site to WP 3.9 and upgraded to Pods 2.4 - all of my Pods have disappeared and the Upgrade Wizard does not appear. Searching through the web for fixes I notice this has happened a few times but cannot find the URL to run the wizard.

    Is there a URL for the wizard or an old version of Pods 2.x I can upgrade to before upgrading to 2.4?

    https://wordpress.org/plugins/pods/

  2. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 10 months ago #

    You should see a "Pods Upgrade" menu in the bottom left of your admin area menu navigation. Do you see that? Are you logged in as the administrator of the site?

  3. pintofmilk
    Member
    Posted 10 months ago #

    Hi Scott, the "Pods Upgrade" menu is not visible in /wp-admin/index.php or when I click 'Pods Admin' link which takes me to /wp-admin/admin.php?page=pods-add-new

  4. Josh Pollock
    Member
    Plugin Author

    Posted 10 months ago #

    Have you tried switching to an older version, such as 2.3.18 (http://downloads.wordpress.org/plugin/pods.2.3.18.zip) and seeing if the upgrade wizard appears from there?

  5. Josh Pollock
    Member
    Plugin Author

    Posted 10 months ago #

    Also, please try from Pods Admin > Settings > Reset, click the delete 2.0 data button, which should initiate a new upgrade process from 1.x

  6. pintofmilk
    Member
    Posted 10 months ago #

    Thanks Josh. Got it working by doing this:
    Move wp-plugins/pods/ folder elsewhere
    Add plugin - Pods 2.3.18
    Go to Pods - Settings - Cleanup & Reset - Deactivate & Delete Pods 2.x Data
    Reactivate plugin
    Refresh page
    Run Pods Upgrade

    Reason I could not do this with 2.4 was the the Template screen appeared broken - PHP not displayed in textarea and 'Associate with Pods' dropdown was broken.

    Thanks for your help,
    Ben

Reply

You must log in to post.

About this Plugin

About this Topic