WordPress.org

Support

Support » Installation » Upgrade tot 3.1 leaves website blank: Fatal error!

Upgrade tot 3.1 leaves website blank: Fatal error!

  • Martijnchel
    Participant

    @martijnchel

    Hi,

    I got this fatal error when I upgraded to 3.1:

    Fatal error: Class ‘WP_List_Table’ not found in /usr/home/deb18228n2/domains/homecinemamagazine.nl/public_html/wp-admin/includes/list-table.php on line 76

    Restoring my backup does not even help..

    What can I do?
    Please help!

Viewing 15 replies - 1 through 15 (of 51 total)
  • Me too help….

    wideblueyonder
    Member

    @wideblueyonder

    Same boat – upgraded to 3.1 and wordpress site, including admin sections completely blank white screen

    Windows server 2003 for my wordpress (my rented server).

    just updated one of my several wordpress sites to 3.1 – just killed it

    the admin still works, but the public visible side won’t load up.

    The page isn’t redirecting properly

    http://www.pdc-darts.co.uk

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    * This problem can sometimes be caused by disabling or refusing to accept
    cookies.

    i’ll add i tried renaming the plugin directory to plugins.hold, and creating a new plugins directory – refreshed admin, and all the extras disappeared, but still same error on front end of site.

    then changed to default theme – still same error. so it doesnt’t appear to be plugin or theme related?

    Martijnchel
    Participant

    @martijnchel

    Anyone who has the pluging WPeMatico installed!!
    Delete it from your FTP server.. WP 3.1 does not like it! And it causes the error I had.

    I had WPeMatico on that site. Delete it and is working all good. Great job Martijnchel!

    AardvarkGirl
    Member

    @aardvarkgirl

    krispy_b
    I had the same exact issue. We have control of our server.

    See my other posts about everything I have done. I ran the auto update on one of our clients sites and the site went blank (actually got an error in Chrome and FF that it is in a loop). Then I ran the auto update on our WP test site (used to just develop themes). It killed that one too.

    So with the test site I tried a manual update – didn’t work. Then I killed all the files and the database and tried a brand new, fresh install of 3.1 and got the same thing (full access to admin area but the front end hung in a loop / blank page).

    I finally killed the entire thing and just reinstalled 3.0.5 with a clean database and it works fine.

    My clients site that is still in ‘upgrade-loop-limbo’ is still there. I’ve given up, only two people have replied to my two threads. I’m digging into the server back ups of the database from yesterday and I’m going to kill everything and just totally reinstall the ‘limbo’ site again using 3.0.5 and just import the backed up ‘pre update’ database. :-\

    Cameback to edit that my limbo site does not have that plug in installed – and actually from the admin area it let me deactivate all my plug ins, but it still won’t function on the front end.

    I tried to go in and change the plug in folder name, not just via FTP but via remote desktop, and it would not give me access (seriously?). I even started/stopped the website in IIS.

    wideblueyonder
    Member

    @wideblueyonder

    Are you folks able to see/get to the admin pages? I currently get nothing at all – everything is blank/white whatever I try.

    I have tried renaming the plugins folder in wp-content but this made no difference.

    Anyone have any other suggestions.

    I see the admin pages at least.

    AardvarkGirl
    Member

    @aardvarkgirl

    I can get to my admin side and do things, like disable plug ins, and even pre-view pages.

    I just can’t get to the site from the front end.

    I managed to get this to go away by commenting out the function that was causing the error. I then found that one of the plugins I had installed (backWPup) was trying to call the same code and also failing.

    Removed the whole plugin (by deleting the directory) and my site came back up.

    Obviously this is a temporary fix, but at least the site is there again.

    Two of my sites (recently created with minimal content and up-to-date WP installs) upgraded with no problems, but my third one had this issue. Will be waiting to upgrade the fourth and most important!

    AardvarkGirl
    Member

    @aardvarkgirl

    I upgraded two sites.

    One only had Google Analyticator and was in deactivated mode, and My Page Order.

    The other site had… deactivated Akismet and uh… I don’t believe anything else?

    Didn’t matter. I could get in and deactivate all plug ins but both sites still tanked on the front end.

    wideblueyonder
    Member

    @wideblueyonder

    My Issues are now SOLVED.

    Recap of Problem – used auto-update from WP dashboard
    After update whole site went blank – plain white page with no access to either front or backend.

    Solution: Downloaded 3.1 from wordpress.org and used .ftp to do a manual update which has brought the site back to life.

    Instructions for manual upgrade can be found here: http://codex.wordpress.org/Updating_WordPress

    BigFeat
    Participant

    @bigfeat

    I’m unable to get into my dashboard. I get this message Fatal error: Call to undefined function is_network_admin() in D:\Hosting\7352934\html\wp-admin\includes\menu.php on line 10

    How do I fix this?

    esmi
    Forum Moderator

    @esmi

    Try:
    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to access /wp-login.php to get this to kick in fully.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-running the upgrade manually

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘Upgrade tot 3.1 leaves website blank: Fatal error!’ is closed to new replies.