Support » Plugin: MyBooks for Authors, by Out:think Group » Upgrade to WP 3.6 broke my site

  • Resolved yakos

    (@yakos)


    Upgrade to WP 3.6 from 3.5.2 broke my website with the following error.

    Fatal error: Cannot redeclare has_shortcode() (previously declared in /home2/diaspor5/public_html/wp-includes/shortcodes.php:153) in /home2/diaspor5/public_html/wp-content/plugins/mybooks-for-authors/ot-functions.php on line 49

    As soon as I disabled this plugin, my website came back up.
    Do you have a version that works with WP 3.6 ?

    I really like this plugin and have been using it on my literature website, however now I don’t know if I have lost all books and reviews we have done over the years.

    http://wordpress.org/plugins/mybooks-for-authors/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Joseph Hinson

    (@jhinson)

    Hi Yakos,

    Yeah, when I saw that WordPress had a function called “has_shortcode”, one I also created…I knew it would break in 3.6.

    No worries though, I have the fix and will update it by tomorrow.

    Hang tight, and you’ll be able to just run the upgrade and it’ll be fixed.

    Hello together,

    i have the same problem by updating to 3.6.
    But i can’t do anything.
    Here is the message:
    Fatal error: Cannot redeclare has_shortcode() (previously declared in /.../wp-includes/shortcodes.php:153) in /.../wp-content/themes/showycase/functions.php on line 247

    What can i do?

    Thanks!

    @la_root – your error is not from this plugin – it’s from your theme – see this: themes/showycase. You will need to use FTP to deactivate the theme – you can find it in the theme’s folder here:

    wp-content
         themes
             showycaseHOLD

    Then you need to ask your theme developer about fixing the problem – as commercial themes are not supported on these forums.

    If you need additional help with deactivating the theme, please start your own thread in the correct forum here:

    How-To and Troubleshooting

    My problem is fixed once I upgraded to the latest version of MyBooks for Authors. Thanks

    Plugin Author Joseph Hinson

    (@jhinson)

    You’re very welcome @yakos.

    I upgraded to WordPress 3.6 and the site went down. When the site went down this was on the page Fatal error: Cannot redeclare has_shortcode() (previously declared in /home/……/public_html/wp-includes/shortcodes.php:153) in /home/……./public_html/wp-content/themes/options2/framework/functions/common.php on line 23

    Can someone please help me with a code to change so I can continue to use the theme? I have used this theme on several sites and I can’t upgrade them to 3.6 until I can get this fixed.

    @ppma: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem has nothing to do with this plugin.

    I apologize.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Upgrade to WP 3.6 broke my site’ is closed to new replies.