WordPress.org

Support

Support » Plugins and Hacks » [Resolved] upgrade to WP 3.2 broke BackWPup

[Resolved] upgrade to WP 3.2 broke BackWPup

  • after upgrading to WP 3.2 and calling the plug-in we got the following error message:

    Fatal error: Call to undefined method WP_List_Table::WP_List_Table() in …/wp-content/plugins/backwpup/app/list-tables.php on line 8

Viewing 7 replies - 1 through 7 (of 7 total)
  • Some member said that backWPup v1.7.x version only for wordpress 3.1.x.
    So, I have to wait backWPup v.2.0 released before upgrading to wordpress 3.2.

    Hope plugin coder releses 2.0 soon

    Got the same error too. But it’s WordPress 3.2’s problem.

    I manually modify code wp-admin\includes\class-wp-list-table.php line 80, from
    function __construct( $args = array() ) {
    to
    function WP_List_Table( $args = array() ) {

    Just fixed the problem.

    Plugin Author Daniel Hüsken
    Participant

    @danielhuesken

    update come in the next houers.

    Daniel – thank you for your quick response. It is an awesome plugin and we hate to see it broken “;->

    chiangww – thanks for the line of code. We’re holding our breath for Daniel’s fix. When turning blue we’ll give your fix a try.

    Again – awesome plugin!

    Cheerio

    Plugin Author Daniel Hüsken
    Participant

    @danielhuesken

    is fiexed with 2.0.0

    awesome and ‘THANK YOU’!!

    New Error!!!
    Warning: in_array() expects parameter 2 to be array, null given in /usr/share/web/XYZsite/webshare/wordpress/wp-content/plugins/backwpup/pages/func_backwpup.php on line 248

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] upgrade to WP 3.2 broke BackWPup’ is closed to new replies.