Support » Plugin: The GDPR Framework By Data443 » Upgrade to PHP 7.2

  • Resolved christian984

    (@christian984)


    Hi! I’m about to upgrade my site to PHP 7.2, and I’m getting the following Warning and Error messages. It would be great to get them fixed to ensure things will be compatible!

    FILE: /plugins/gdpr-framework/vendor/paragonie/random_compat/lib/random_bytes_mcrypt.php
    ——————————————————————————————————————————————————
    FOUND 3 ERRORS AFFECTING 1 LINE
    ——————————————————————————————————————————————————
    58 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    58 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
    58 | ERROR | The constant “MCRYPT_DEV_URANDOM” is deprecated since PHP 7.1 and removed since PHP 7.2
    ——————————————————————————————————————————————————

    FILE: /plugins/gdpr-framework/vendor/paragonie/random_compat/lib/byte_safe_strings.php
    —————————————————————————————————————————-
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————————————————-
    32 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    86 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ————————————————————————————————————-

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.