Support » Installing WordPress » Upgrade to php 5.4 Causes Error

  • sgignac

    (@sgignac)


    I use 1&1 to host my website. It is asking me to upgrade from php 5.2 to 5.4.

    First I updated wordpress to 3.5.1, and updated all my plugins. Then I switched to 5.4.

    Now I have this error at the top of my site:
    http://www.sarahgignac.com
    Warning: Illegal string offset ‘name’ in /homepages/38/d288486085/htdocs/home2/wp-content/plugins/genesis-simple-sidebars/plugin.php on line 106

    Warning: Illegal string offset ‘description’ in /homepages/38/d288486085/htdocs/home2/wp-content/plugins/genesis-simple-sidebars/plugin.php on line 108

    Line 106 is ‘name’ => esc_html( $info[‘name’] ),

    Line 108 is ‘description’ => esc_html( $info[‘description’] ),

    I’m not a programmer, so I don’t know what to change without potentially making it much worse.

    Thanks!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Upgrade to php 5.4 Causes Error’ is closed to new replies.