Support » Plugin: Yoast SEO » Upgrade to latest version triggers HTTP ERROR 500

  • Resolved aguett

    (@aguett)


    Hi guys,

    I just updated the plugin on my site and it triggered a HTTP ERROR 500.

    It seems like yoast is not happy at all :

    2017/08/08 13:39:12 [error] 24907#24907: *489 FastCGI sent in stderr: “PHP message: PHP Fatal error: Call to undefined method WPSEO_Utils::is_yoast_seo_premium() in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 171” while reading response header from upstream, client: 111.222.111.123, server: mydomain.com, request: “GET /wp-admin/edit.php?post_type=page HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “mydomain.com”, referrer: “http://mydomain.com/wp-admin/plugins.php?plugin_status=upgrade”
    2017/08/08 13:39:22 [error] 24907#24907: *492 FastCGI sent in stderr: “PHP message: PHP Fatal error: Call to undefined method WPSEO_Utils::is_yoast_seo_premium() in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 171” while reading response header from upstream, client: 111.222.111.123, server: mydomain.com, request: “GET /wp-admin/ HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “mydomain.com”
    2017/08/08 13:39:45 [error] 24907#24907: *504 FastCGI sent in stderr: “PHP message: PHP Fatal error: Call to undefined method WPSEO_Utils::is_yoast_seo_premium() in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 171” while reading response header from upstream, client: 111.222.111.123, server: mydomain.com, request: “GET /wp-admin/plugins.php?plugin_status=upgrade HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “mydomain.com”
    2017/08/08 13:41:01 [error] 24907#24907: *513 FastCGI sent in stderr: “PHP message: PHP Fatal error: Call to undefined method WPSEO_Utils::is_yoast_seo_premium() in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 171” while reading response header from upstream, client: 111.222.111.123, server: mydomain.com, request: “GET /wp-admin/plugins.php?plugin_status=upgrade HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “mydomain.com”, referrer: “http://mydomain.com/wp-admin/plugins.php”
    2017/08/08 13:44:49 [error] 24907#24907: *528 FastCGI sent in stderr: “PHP message: PHP Warning: strpos(): Empty needle in /home/nginx/domains/mydomain.com/public/wp-includes/plugin.php on line 649
    PHP message: PHP Warning: include(/home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-yoast-alerts.php): failed to open stream: No such file or directory in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186
    PHP message: PHP Warning: include(): Failed opening ‘/home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-yoast-alerts.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186
    PHP message: PHP Fatal error: Class ‘Yoast_Alerts’ not found in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 371” while reading response header from upstream, client: 111.222.111.123, server: mydomain.com, request: “GET /wp-admin/plugins.php?plugin_status=upgrade HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “mydomain.com”
    2017/08/08 13:44:54 [error] 24907#24907: *528 FastCGI sent in stderr: “PHP message: PHP Warning: strpos(): Empty needle in /home/nginx/domains/mydomain.com/public/wp-includes/plugin.php on line 649
    PHP message: PHP Warning: include(/home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-yoast-alerts.php): failed to open stream: No such file or directory in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186
    PHP message: PHP Warning: include(): Failed opening ‘/home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/admin/class-yoast-alerts.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186
    PHP message: PHP Fatal error: Class ‘Yoast_Alerts’ not found in /home/nginx/domains/mydomain.com/public/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 371” while reading response header from upstream, client: 111.222.111.123, server: mydomain.com, request: “GET /wp-admin/ HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “mydomain.com”

    Unfortunately it seems like renaming the plugin in the plugin directory doesn’t solve my problem so I’m really stuck.

    Any idea ?

    Cheers,

    • This topic was modified 2 years, 2 months ago by  aguett. Reason: masked ip
Viewing 4 replies - 1 through 4 (of 4 total)
  • agree
    I got the same error

    Yesterday (when I opened the ticket) I’ve been able to login from a different IP.

    Today I can reach the site again from my old IP.

    My guess is that the upgrade does something that nginx and/or the firewall, doesn’t like, which triggers the firewall to boot you out of WP.

    Plugin Support marcanor

    (@marcanor)

    That sounds like a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Plugin Support jerparx

    (@jerparx)

    Closed due to inactivity.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upgrade to latest version triggers HTTP ERROR 500’ is closed to new replies.