Support » Plugin: WordPress Zero Spam » Upgrade to 5.0.2 crashes site

  • Resolved pik256

    (@pik256)


    After (automatic) upgrade to current version (5.0.2) my site has crashed. I cannot even log in to it. I deleted all plugin files and could log in. Then I installed the plugin once more, activated it but the same error occured. So I had to remove the plugin.
    Windows IIS server, PHP 7.4.11
    This is an error log:

    `[24-Feb-2021 13:13:46 UTC] PHP Fatal error: Uncaught Error: Class ‘ZeroSpam\Includes\DB’ not found in wp-content\plugins\zero-spam\includes\class-plugin.php:143
    Stack trace:
    #0 wp-content\plugins\zero-spam\includes\class-plugin.php(119): ZeroSpam\Plugin->init_components()
    #1 wp-includes\class-wp-hook.php(287): ZeroSpam\Plugin->init()
    #2 wp-includes\class-wp-hook.php(311): WP_Hook->apply_filters()
    #3 wp-includes\plugin.php(484): WP_Hook->do_action()
    #4 wp-settings.php(557): do_action()
    #5 wp-config.php(93): require_once(‘…’)
    #6 wp-load.php(37): require_once(‘…’)
    #7 wp-admin\admin.php(34): require_once(‘…’)
    #8 wp-admin\plugins.php(10): require_once(‘…’)
    #9 {main}
    thrown in wp-content\plugins\zero-spam\includes\class-plugin.php on line 143`

    • This topic was modified 8 months ago by pik256.
    • This topic was modified 8 months ago by pik256.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ben Marshall

    (@bmarshall511)

    @pik256 I’m unable to replicate this issue. Please update to the latest (5.0.3) and let me know if you’re still running into it.

    Thread Starter pik256

    (@pik256)

    The same error in 5.0.3:

    `[24-Feb-2021 14:25:55 UTC] PHP Fatal error: Uncaught Error: Class ‘ZeroSpam\Includes\DB’ not found in wp-content\plugins\zero-spam\includes\class-plugin.php:144
    Stack trace:
    #0 wp-content\plugins\zero-spam\includes\class-plugin.php(120): ZeroSpam\Plugin->init_components()
    #1 wp-includes\class-wp-hook.php(287): ZeroSpam\Plugin->init()
    #2 wp-includes\class-wp-hook.php(311): WP_Hook->apply_filters()
    #3 wp-includes\plugin.php(484): WP_Hook->do_action()
    #4 wp-settings.php(557): do_action()
    #5 wp-config.php(93): require_once(‘…’)
    #6 wp-load.php(37): require_once(‘…’)
    #7 wp-blog-header.php(13): require_once(‘…’)
    #8 index.php(17): require(‘…’)
    #9 {main}
    thrown in wp-content\plugins\zero-spam\includes\class-plugin.php on line 144`

    BTW. I can see class DB definition in includes/zero-spam.php file, but I cannot find ‘require’ or ‘include’ for this file in zero-spam sources.

    Plugin Author Ben Marshall

    (@bmarshall511)

    @pik256 It’s loaded via the autoloader, doesn’t need to be explicitly included. I’m not able to replicate this, so can’t see what’s going on. Can you provide me a log in to the site or a copy so I can try to track down what’s going on with your instance? You can email me at me@benmarshall.me

    Plugin Author Ben Marshall

    (@bmarshall511)

    This is fixed in the next release. Issue-specific to Window’s servers. https://github.com/bmarshall511/wordpress-zero-spam/pull/236

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upgrade to 5.0.2 crashes site’ is closed to new replies.