Support » Fixing WordPress » Upgrade to 3.6 stalls at unpacking

  • Resolved MacDoodle


    Trying to upgrade from 3.5.2 to 3.6 via dashboard/updates. Goes as far as “Unpacking blah blah blah…” and stops. Fortunately, the old install isn’t damaged so everything is still working.

    The site isn’t even close to exceeding quota, and is not in a shared environment.

    FWIW – I was able to upgrade my test installation on a different server, with all the same plugins setup.

    Any suggestions where to look?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator t-p


    Right. I did read the page at the link you provided.

    *I used proper capitalization & a descriptive subject line.
    *I was patient! I didn’t even reload the board once!
    *I made my own topic.
    *Hasn’t been resolved yet, so…
    *I never feel alone when I’m here. <3

    *I read the Codex, I do that prior to ANY upgrades, nothing seemed extraordinary.

    As I said I did the upgrade first on my test site with all the same plugins running. It worked fine.

    The server that won’t unpack doesn’t give the owner access to “flush caches”. In fact, I don’t think I’ve used a server that allows someone hosted on it to flush a cache.

    I didn’t think there was a need to deactivate all plugins because as I said above, it never finishes unpacking. I’m not sure how active plugins would affect that – and also, it installed on the test server without shutting off all plugins, no problem.

    Ironically, this site is using a child theme of 2012. So, yeah, not that.

    Maybe I should have said “Any suggestions where to look ON THE SERVER” because I’m thinking that may be where the problem is mainly because Server A = update OK! Server B = update NOT OK!

    BTW – I did upgrades on two other sites without problem before coming back here to respond. Not on the same web host, but update went fine, nonetheless.

    I could do a manual update, which is fine, but that doesn’t answer the question of why won’t it go past the unpacking and begs the question is something else broke that I need to address before it causes a huge problem on a very active site. Which I know is NOT the problem of WordPress, but figuring out why there is a problem with the wordpress upgrade could help me to solve the (potential) problem.

    I’ve played with this a little more today, including turning off all plugins, removing everything from the htaccess file except the permalinks info. No joy.

    All of the plugins that needed updating updated without problem. (Contact form 7 & Easy Fancy Box).

    Double checked quota (60% free), double checked PHP memory (128MB), etc.

    The site is using a child theme of Twenty Twelve, using only a few custom files (one additional template and css).

    I was given access to do the same update on the same type of server (less quota) and that went fine.

    This site has been setup with WordPress since 2007, updates are done on a regular basis and we have never had the problem of an update stalling out like this.

    I’m stumped.

    As I said, this is a busy site, during their busy time of year, and the site is responsible for their daily schedule for visitors. There just isn’t a good time to take it offline for 20 – 30 minutes to do an update that should, in theory, only take a few minutes to do.

    Any other suggestions would be deeply appreciated.

    Have you done a manual update?

    There just isn’t a good time to take it offline for 20 – 30 minutes to do an update that should, in theory, only take a few minutes to do.

    I was referring to a manual update there. I’m sorry for not being more clear.

    I’ve also watched the logs while trying to do the update. All I see is me posting to the update-core.php file, and then it stops. No errors. Nothing.

    Went for a walk & swim, came back and started poking at this again, and it worked. I have absolutely no idea why. I tried all the same things.

    The only thing that even remotely comes close to being different is I put two sections of the htaccess file in a different order

    These two sections –

    (blah blah)
    <Limit GET>
    blah blah blah

    Changed to

    <Limit GET>
    blah blah blah
    (blah blah)

    It’s not a browser cache thing – every time I made a change, I would close the browser, start it back up. My browser is set to clear EVERYTHING when I close it – cookies, cache, history, etc.

    If you come across this post in the future and you know why that may have made a difference, let me know. 😉

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Upgrade to 3.6 stalls at unpacking’ is closed to new replies.