Support » Installing WordPress » Upgrade to 3.5 disabled the visual editor

  • Resolved ericht


    My wordpress blog was recently changed to version 3.5 and since the update my visual editor does not work, either on new posts or old posts (all that shows up is the HTML tab).

    I tried the following fixes that were recommended in previous forum posts, and none helped:
    – tried on three different browsers (IE, Safari, and Chrome): broken on all three
    – tried clearing the browser cache
    – deactivated all plugins
    – reinstalled version 3.5
    – changed to the 2012 theme (this did not work so I restored my previous theme)

    Please advise on any other approach I can take to resolve the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p


    -Try adding this to the wp-config.php: define(‘CONCATENATE_SCRIPTS’, false); to the bottom of your wp-config.php file (just before the require_once line). First, make sure that your browser has JavaScript enabled.

    I had the same problem. I have over fifty WordPress installations. Some of my sites had problems after the auto upgrade. None of the sites that I manually upgraded had issues. After doing all the usual tricks a complete manual re-intall was the only solution that worked. I use Host Gator. I followed the steps here with the following exceptions:

      I created a new “Old Files” folder.
      I moved all the files except the WP-Content folder to the new old files folder.
      I downloaded the latest WorddPress 3.5 to my local PC.
      Extracted the files and deleted the WP-Content folder then re-compressed.
      Uploaded to the server and extracted them.
      Copied the WP-Config.PHP back to the root.

    Make sure to disable all Plugin-ins. Then re-enable after manual install.
    After that everything was good as new.
    Hope that helps.

    I was able to get my service provider to make the change to my config file and restore the visual editor. Hopefully future updates will be a bit smoother than this one (the tech who helped me let me know that this is a widespread problem and she has assisted many people with it.

    Thank you,

    So I am sitting here in the hostgator queue with the second person now, they seem clueless and unaware that this is a widespread problem. This is definitely the same issue you both have described (pushed update & no access to visual editor) and I have read elsewhere also. Any tips to clue them in as to what we need fixed?

    @lauraseo – this thread is marked resolved – so you are not likely to get help by posting in it. Please start the troubleshooting steps in this post:

    And then start your own thread if you need additional help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Upgrade to 3.5 disabled the visual editor’ is closed to new replies.