[resolved] Upgrade to 3.5 (3 posts)

  1. kellydigital
    Posted 2 years ago #

    after upgrading to 3.5 my clients site no longer works - and I can't log into wp-admin either .

    I get the following error: Warning: Missing argument 2 for wpdb::prepare(),

    can anyone help?


  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Fortunately, that's a known and fixable problem :). See the last post in this thread:


  3. kellydigital
    Posted 2 years ago #

    Thanks for pointing me in the right direction!

    i'm using the Revelation theme...and I also had to make the following changes to make it work again:

    For anyone receiving the wpdb::prepare() error, add this content to your wp-config.php file at the very bottom:
    ini_set( 'display_errors', false ); error_reporting( 0 );

    Then, replace line 51 in /lib/theme-sidebars.php with this:
    $widgetized_pages = $wpdb->get_col("SELECT DISTINCT meta_value FROM $wpdb->postmeta WHERE meta_key = 'jw_sidebar'");

    That fixed the error messages for me and allowed me to access both the website and the admin area.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.