WordPress.org

Support

Support » Installation » [Resolved] Upgrade to 3.2.1 – wp-admin login failed – memory problem

[Resolved] Upgrade to 3.2.1 – wp-admin login failed – memory problem

  • Hi,

    I have a problem after update from 3.1.4 to 3.2.1. On admin login page, after I put admin name and password I’m getting this error:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 122880 bytes) in /home/zbirkos/www/autoblog/wp-admin/includes/dashboard.php on line 89

    Here is phpinfo: http://automotiveblog.pl/phpinfo.php

    I tried to rename plugins folder to pluginsold and tried to login again to admin panel but unfortunatelly problem is still there.

    Tried to add define(‘WP_MEMORY_LIMIT’, ’64M’); to WP config file and similar to .htaccess but it also haven’t resolved my issue.

    Does anybody know how to resolve it?

Viewing 15 replies - 1 through 15 (of 20 total)
  • esmi

    @esmi

    Forum Moderator

    Try switching to the default theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    You could also try resetting the plugins folder by phpMyAdmin. Some really bad plugins need the Phpmyadmin method to drive the equivalent of a stake through them.

    Tried both things, still not resolved πŸ™

    After update of PHP version on server to 5.3.5 right now I got the same error but on different line:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 122880 bytes) in /home/zbirkos/www/autoblog/wp-admin/includes/dashboard.php on line 710

    I disabled plugins from PhpMyAdmin and now I got:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 122880 bytes) in /home/zbirkos/www/autoblog/wp-admin/menu-header.php on line 96

    esmi

    @esmi

    Forum Moderator

    You may need to speak to your hosts about checking/increasing the memory available to you.

    OK case solved, this is what I did:

    1) Updated PhpMyAdmin on serwer to version 5.3.5
    2) I logged in to FTP account and changed wp-includes and wp-admin to wp-includesOLD and wp-adminOLD
    3) I downloaded WordPress zip package, unzip it on harddrive and uploaded to FTP account
    4) I loged in to admin panel. There was a message that my DataBase has to be configured. I waited couple of seconds and without problems I saw admin panel. But there was a message that new version 3.2.1 was not installed properlly. I clicked link to install, it took 2-3 seconds and message dissapeared.

    After confirmed that it works I deleted wp-adminOLD and wp-includesOLD

    Thank you zbirkos. That worked like a charm and the step by step instructions were very helpful. πŸ™‚

    zbirkos – you are a life saver. This one had me at a standstill for almost a week.

    All, I followed these exact steps (1-4) and my the errors were resolved immediately.

    Thanks again!

    Mark

    Well this error is nothing new for many of us. To fix this error, simply follow this:

    1. Goto your wordpress root directory

    Either login via ftp or use the filemanager if your web host provides you with this feature (to get a cpanel based hosting click here).

    2. Edit the config file

    In your wordpress 3.0 installation root folder, find the file named:

    config.php

    Open the file to be edited in your favorite editor

    3. Add the code to file and save

    Add this code to your config.php file ( type it manually if it don’t work on copy / paste )

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    after the lines :

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    Save the file and refresh your wordpress page and it should not give the error again.

    If the error still appears then try changing 64M to 128M.

    shahzadsmb, thanks for the input. I went through those steps as well.

    Just for the record, in my case, this wasn’t resolved until i followed zbirkos’ previous advice.

    thx zbirkos – you rock !!

    anyone work out why this is happening in the first place ?
    i upgraded my PHP version on server to 5.3.8

    And i set my cache and upload folders to 777 just inc ase before i tried auto updating wordpress – it is happening on all my wordpress sites when trying to upgrade them from wp-admin

    regards – glen

    Hi,
    I have the same issue since updating from 3.1.4 to 3.2.1.
    I have tried the above fixes but to no avail.Anyone else have suggestions?

    Hi zbirkos,

    Your solution is the only way that can resolve my problem, after trying a bunch of other methods, eg, define(‘WP_MEMORY_LIMIT’, ’64M’);

    It works like a charm. Thank you so much!

    zbirkos steps worked for me too — without the PHPmyAdmin upgrade (I’m using 3.4.5).

    Thanks.

    zbirkos’s procedures works (for me, without upgrading phpmyadmin). Very cool. Most people would just recommend adding more memory in config.php file which isn’t working in most cases. THANKS

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Upgrade to 3.2.1 – wp-admin login failed – memory problem’ is closed to new replies.