Support » Fixing WordPress » Upgrade to 3.1.3 breaks Visual Editor on Images

  • I’ve deactivated all plugins to test it isn’t a compatibility issue, but in IE and FF, hover over an image and pressing the EDIT image icon button produces this text in a pop up window.

    # $Id:,v 2009/03/08 09:32:11 hass Exp $ # # LANGUAGE translation of Drupal (date_locale) # Copyright YEAR NAME # Generated from files: # date_locale.module,v 2009/01/25 13:03:13 karens #,v 2009/01/25 13:03:13 karens # msgid “” msgstr “” “Project-Id-Version: \n” “POT-Creation-Date: 2009-03-07 19:12+0100\n” “PO-Revision-Date: 2009-03-07 19:46+0100\n” “Last-Translator: Alexander Haß\n” “Language-Team: \n” “MIME-Version: 1.0\n” “Content-Type: text/plain; charset=utf-8\n” “Content-Transfer-Encoding: 8bit\n” “Plural-Forms: nplurals=2; plural=(n!=1)\n” “X-Poedit-Language: German\n” “X-Poedit-Country: GERMANY\n” #: date_locale/date_locale.module:152 msgid “Language” msgstr “Sprache” #: date_locale/date_locale.module:160 msgid “Search” msgstr “Suche” #: date_locale/date_locale.module:176 msgid “Date format settings for %language_name” msgstr “Datumsformat-Einstellungen für %language_name” #: date_locale/date_locale.module:45 msgid “Locale date settings” msgstr “Lokale Datumseinstellungen” #: date_locale/date_locale.module:46 #, fuzzy msgid “Configure date formats for each locale” msgstr “Datumsformate für jede Lokale konfigurieren” #: date_locale/date_locale.module:0 msgid “date_locale” msgstr “date_locale” #: date_locale/ #, fuzzy msgid “Date Locale” msgstr “Datums-Lokale” #: date_locale/ msgid “Allows the site admin to configure multiple formats for date/time display to taylor dates for a specific locale or audience.” msgstr “Ermöglicht einem Website-Verwalter mehrere Formate für die Datum/Zeit-Anzeige zu konfigurieren, um Termine für eine spezielle Lokale oder Zielgruppen maßzuschneidern.”

    Right clicking produces the context menu which says insert/edit image, but it only inserts.

    Looks like the Visual Editor has got issues with editing images. (Was on 3.1.2 previously and that was OK). I can’t find any simialr issue to apply a fix. Any ideas anyone? Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.


    Yes, I deactivated all plugins and swapped the theme to Twenty Ten. I used PHPMYAdmin to change the active_plugins value as well as creating a new blank plugins directory and uploading a fresh set of wp-admin and wp-includes; the problem still occurs.

    Update: I just looked at the log for the upload and two files failed (I assume they failed when I did the initial upgrade). These were two TinyMCE files.

    Now the problem has changed:-

    FF works fine
    IE9 gives the error message
    Chrome just sits there after pressing the edit button
    IE6 in a virtual machine works fine.

    Update #2

    A clean install of Chrome in a XP VM worked fine.
    Opera in XP VM works fine.

    Win7 64 Bit OS:
    FF, Chromium, Opera all work OK.

    Chrome in normal and Incognito mode just sits there after the press of the edit button. Delete button does nothing.

    IE9( both 32 and 64 bit) sit there on the first image, but produce the error on subsequent images. Delete works OK.

    I’ve installed latest version of Chrome and Java but still no luck.

    Guess I’ll stick with Chromium to edit my image details.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upgrade to 3.1.3 breaks Visual Editor on Images’ is closed to new replies.