WordPress.org

Support

Support » How-To and Troubleshooting » Upgrade to 3.1.1 error

Upgrade to 3.1.1 error

  • I tried to upgrade automatically to 3.1.1, but it failed and I got this message:

    Cannot redeclare class Plugin_Upgrader in …../public_html/wp-admin/includes/class-wp-upgrader.php on line 594

    I’ve done many auto updates on this server; first time this happened.

    Any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    @esmi

    Forum Moderator

    Sounds like your upgrade did not complete successfully.

    Try:
    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade manually using wp-admin/upgrade.php.

    Im getting exact same problem on multiple blogs

    I, too, am having the same issue on all of my WordPress sites to 3.1.1.

    Perhaps the release came a bit too quickly?

    I ended up manually uploading the new release. We’ll see what happens during the next update.

    BTW Esmi, the automatic update didn’t kill my site: my blog still worked. It just gave me the error and prompted me again to upgrade. I assume that’s why you asked me to rename my theme’s folder rather than simply activate twenty-twenty in Admin?

    Oh, and switching the theme to the default didn’t work anyway. Thanks for the suggestions, though!

    Same here …

    Help…, I tried to upgrade automatically to 3.1.1, but after done I got this message:
    Fatal error: Call to undefined function get_option() in /home/artpuls1/public_html/wp-admin/admin.php on line 32

    I’ve done many auto updates on this server; first time this happened.

    Any Ideas ???

    ( Sorry, my english is bad, so i’ve copy paste the messages same above 🙂 )

    You might have to upgrade manually. That’s what I ended up doing. Like you, my install has been on the same server for a while now and I never had any problems upgrading automatically before.

    This version (3.1.1) sucks. It has many issues updating. My blog works, but when Im trying to get into admin panel, it displays an error. The only way to get into it, is renaming the “Plugins” folder, after that you will have access.

    I think they should release a new version to fix all this problems cause many people is having the same.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Upgrade to 3.1.1 error’ is closed to new replies.
Skip to toolbar