Support » Installation » Upgrade to 3.1 – wp_cache_get() issue

Upgrade to 3.1 – wp_cache_get() issue

  • Did the auto upgrade to 3.1

    Immediately got the following error

    Fatal error: Call to undefined function wp_cache_get() in /home/content/*********************/wp-includes/functions.php on line 336

    Nothing works. Will attempt to roll back. Hopefully not a problem.

Viewing 15 replies - 16 through 30 (of 31 total)
  • Great stuff poimenJohn but I think most of us need to use it going forward so we need to find a way to keep on adding and initializing new sites

    Thanks for the interim solutions guys. Now, we can either stay with WordPress 3.05 or make some changes to the wp-ive code. At least that solves the immediate problem.

    Longer term, I wonder if there’s anyone willing to take over wp-hive. If it’s critical to many people, maybe there’s enough interest to raise some donations to make it worthwhile putting in the time and effort.

    Just a thought…

    I know what’s wrong and what needs to be done to get it working with WP 3.1. It’s not a hard fix.

    But it’s a long way from posting a patch here and distributing a fully tested plugin and maintaining it for the future.

    I’m thinking about it.

    But in the mean time, next week I will post a more complete fix for WP 3.1 that will allow new sites to be added.


    J, the fix posted above worked perfectly and all sites are recovered.

    Looking forward to your next update as well,


    I recently upgraded to 3.0.5 and my traffic has disappeared. I was averaging over 400 views a day and since the upgrade my traffic stopped and when I attempt to submit a permalink to my Blog Carnival or Digg I receive the message that the URL is unable to be found. My blog is http://newthoughtgeneration.com

    After doing some testing, I believe wp-hive works fine with the modifications above. I had no problem adding new sites.

    Please let me know if you find a problem. I’ll try to help.

    Can someone please test this version?


    Once I get confirmation that it works with 3.1 and 3.0.5, I will tag it as stable.


    It works in both! Thank you so much for fixing this, I know you’re not developing the plugin anymore, but it’s an amazing one, much better than anything else that’s available!

    Thanks again!

    thanks ikailo for your return!

    Thanks very much ikailo.

    I installed the updated version without any problems. I only have one site at the moment, so I can’t comment on its functionality until I add some more – which I plan to do in the next few weeks.

    Great work!

    It works on WP 3.1.1 and no problems so far.

    Thank you ikailo.

    Unfortunately I see another error with WP Hive 0.6.2 on WP 3.1.1:

    Fatal error: Call to a member function suppress_errors() on a non-object in /home/www/blog/wp-content/plugins/wp-hive/includes/class.wphive.php on line 69

    The error shown in previous email is solved at least for now. I updated to WP Hive 0.62 but I forgot to also copy the file db.php to wp-conent





    should be

    Do we need to copy over the db.php file for this fix to work…

    from this post, it seems that all we need to do is deactivate the old plugin, delete it, upload the new one, (activate it – this step was not mentioned) and then potentially upgrade WP…

    Can you ikailo/John confirm that I understand the proceedure.

    Or anyone else? I am thrown by the mention of copying the db.php file,


Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘Upgrade to 3.1 – wp_cache_get() issue’ is closed to new replies.