WordPress.org

Support

Support » Multisite » [Resolved] Upgrade to 3.1, lost all admin capability

[Resolved] Upgrade to 3.1, lost all admin capability

  • scottlowe
    Participant

    @scottlowe

    I started with 3.0.5 and with Multi-Site installed. I did an auto-update to 3.1 and had no error messages. Now, when I log back into Admin the title says “mySiteName Global Dashboard”, the Dashboard icon does not open at all, the Profile menu opens but is entirely blank, and there are no other menu items.

    It is as though my Admin was reduced to Subscriber and I have no way to change.

Viewing 15 replies - 1 through 15 (of 40 total)
  • Tara
    Participant

    @t-p

    try:
    -deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually (one-by-one) to find the culprit.

    If you don’t have access to your admin area, try deactivating them manually via FTP or phpMyAdmin.

    -switching to the default theme (“twentyten”) for a moment by renaming your current theme’s folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

    If you don’t have access to your admin area, then access your server via FTP or SFTP or whatever file management application your host provides.

    Ken Spong
    Member

    @mistral7-wporg

    HI, have a similar problem – running 3.1, network upgrade, with subdomains – setup on root.
    I cannot see my network admin area post upgrade, and when I click the link in “Thank you for Updating! Please visit the Update Network page to update all your sites.” I get a message that the page did not re-direct properly.
    Plugins disabled.
    Any ideas?

    Can either of you get to /wp-admin/network/index.php?

    scottlowe
    Participant

    @scottlowe

    Ok…GOT IT!! I deactivated ALL the plugins and everything came back. I followed these instructions:

    http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    All I have to do now is figure out which one (which combination) is the problem.

    Thanks guys.

    Tara
    Participant

    @t-p

    You are welcome. 🙂

    Please mark thread as “resolved” using the dropdown in the right panel so that:
    – others with similar problem can see it as “resolved” and will read this thread for help if they have similar problem.
    -volunteers providing help see it as “resolved” and will not waste time reading this post.

    benjancewicz
    Member

    @benjancewicz

    Scottlowe, I have exactly the same problem. What plugin was the problem?

    benjancewicz
    Member

    @benjancewicz

    Hmm, I deactivated all plugins using PHPMyAdmin and I still can’t get in… any other suggestions?

    Ken Spong
    Member

    @mistral7-wporg

    Tried the FTP method, but no success.
    I can not access /wp-admin/network/index.php? – thought I could but after the FTP job I checked and it won’t accept my password – doesn’t say it is wrong, just no go.
    Then I tried to reset the password – page would not redirect – not sure just what is going on.
    Still have the problem of no network admin.

    @ken. login first. then try to visit that page by typing it in.

    Ken Spong
    Member

    @mistral7-wporg

    Hi Andrea, you are a STAR!
    Maybe there was a bit of cache or such not clearing, but the manual type-in worked a treat. – and I thought life was just a “cut and paste” process. Lesson learned.
    Again, a big THANK YOU.

    Ken Spong
    Member

    @mistral7-wporg

    In a blink, back again – this may be something to do with my settings, but:
    I now can access the network admin by typing in the url /wp-admin/network/index.php?, but I cannot access it by simply clicking on either of the two links at the top of the page
    1= “Thank you for Updating! Please visit the Update Network page to update all your sites.”
    2= “Network Admin”
    I get a re-direct error. Checked cookies settings – Accept 1st party, prompt for 3rd party, accept session cookies, override auto cookie handling.
    Clicking the admin link top of the Network page redirects to the non-network admin page /wp-admin every time

    Also I am finding redirect failures when I do any of the following:

    1. Try to activate a plugin in wp-admin.
    2. Try to activate a plugin in wp-admin/network
    3. Try to add a new plugin in wp-admin/network

    Now here is a puzzle – and maybe a clue??
    When I am in wp-admin/network and go to activate a plugin I get the redirect fault, but I then go to wp-admin area and find the plugin activated…..
    So back to wp-admin/network, activate another plugin, and then refresh the /network page – viola – the plugin shows as activated for the network.
    Sorry to keep bothering you all. It’s a problem of redirects not working it seems.
    Regards
    Ken

    Check your plugins. turn them all off if you can. Does the problem persist?

    scottlowe
    Participant

    @scottlowe

    This is partly in response to benjancewicz question with the hope that it helps others. Also, I am leaving out what DID NOT work.

    First, these are plugins I had installed:

    * Image Slider
    * Lightbox 2 (deactivated)
    * User Access Manager
    * WP-e-Commerce
    * Shadowbox
    * TinyMCE
    * Widget Wrangler
    * Cforms II
    * Tierra Audio Playlist
    * Slideshow Gallery Pro

    (1) I used FTP to rename \plugins to \plugins-hold and created a new, empty \plugins folder.

    (2) I logged into admin and found the Plugins menu notifying me that the plugins could not be found and were deactived.

    (3) While still logged into admin, I used FTP to rename the empty plugins folder to \plugins-sav and renamed \plugins-hold back to \plugins

    (4) I refreshed the Plugins admin and everything showed up as Deactivated.

    (5) I did a Network Activate of the plugins one by one and, sure enough, on choked! It was Tierra Audio Playlist.

    (6) Without logging out I used my (still opened) FTP window and dragged Tierra Audio Playlist into \plugins-sav.

    (7) I refreshed the Plugins admin and it came back. The menu gave me the same “not found” error for the Tierra Audio Playlist plugin.

    (8) I dragged the plugin back from \plugins-sav to \plugins, refreshed the Plugins admin to find Tierra Audio Playlist back again, but deactived.

    (9) I did a proper Delete of Tierra Audio Playlist.

    CONCLUSION: As of this posting, Tierra Audio Playlist was only tested up to 3.0.5. If I were to make any recommendation it would be (1) to deactive all plugsin that are not specifically ready for 3.1 and then bring them on-line one-by-one … with an FTP window open (2) and, (benjancewicz and others), I recommend un-doing what ever you did in phpMyAdmin before trying this procedure.

    Hope this helps. Good luck everyone.

    Ken Spong
    Member

    @mistral7-wporg

    @andrea. Turned off plugins – had to refresh as previous post to see deactivated.
    Still have redirect problem – perhaps I missed a file in the upload of the WP 3.1 files???

    @ken – could be. reupload them, make sure there’s a wp-admin/network/ folder with files in there.

    And disable every single plugin. even the ones in mu-plugins.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘[Resolved] Upgrade to 3.1, lost all admin capability’ is closed to new replies.