WordPress.org

Support

Support » Installation » Upgrade to 3.1: it keeps asking the database to be updated

Upgrade to 3.1: it keeps asking the database to be updated

  • Hi,
    after having upgraded from 3.0.2 to 3.1, it keeps asking:
    ———-
    Database Update Required
    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.
    The update process may take a little while, so please be patient.
    ————-
    THEN:
    ———–
    Update Complete
    Your WordPress database has been successfully updated!
    ——————————————————————

    The blog itself is working (http://www.albertoboccalatte.it/blog/) but it keeps asking for a database update if I log in into administration panel, so I can’t write new posts or do anything.

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to try logging into your site to get this to kick in fully.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-running the upgrade manually.

    Hi,
    I’ve just done what you wrote, and nothing changed.
    Thanks

    Do you have database backups? You might try dropping your wordpress database (be sure you have a working backup before you do that though!) and restoring the backup file.

    Then try to do the database update again.

    Had the same issue. Logging out then back in fixed it for me.

    Probably just a caching issue.

    I’ve already logged out, but nothing changed 🙁

    @schyte
    The owner has a 10 days old backup, I’ll keep it as the last try, because he’d loose a lot of posts.

    Log out, clear your browser cache, then try.

    Yes I’ve cleared the Firefox cache before logging in.

    I had the same problem on 1 of my sites but not the other (different hosts).

    After waiting a couple minutes and trying it again it worked.

    I’d guess wordpress is just having problems accessing your DB, just try again later.

    Yes, I think that there’s a problem in connecting with the sql db, too.
    I’ll try later (I can’t access phpmyadmin right now).

    Esmi,

    You’re posting the same three steps for this problem everywhere.

    For many of us, they don’t work.

    What’s the procedure when those three steps fail?

    Thanks!

    There was a problem connecting with the sql db 😉

    I’m having the exact same issue … how did you correct the problem connecting with the sql db?

    I just told the hosting farm that there were connection issues, and they fixed them.

    Thanks … I’ll try that.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Upgrade to 3.1: it keeps asking the database to be updated’ is closed to new replies.
Skip to toolbar