[resolved] Upgrade to 3.0.4 - Blank Admin Login Page (7 posts)

  1. TonyAwards
    Posted 5 years ago #

    I am trying to log in at my site's /wp-login.php page and am getting a blank page at the url - no username and pw login fields or anything to access the admin dashboard. The site's public face is fine, but am unable to access the admin section.
    I read some posts, went into my cPanel filemanager and tried renaming the plugins folder (to ~public) and created a new plugins folder (empty) but this did not help.
    I have cleared the cache in Firefox, still with no result.
    All was fine about 2+ weeks ago but now when trying to log in I get this totally blank page.
    Does anyone have an idea as to what this is and how to fix it? I'm by no means a WP or php expert and could really use some help. Thank you all.

  2. sasant
    Posted 5 years ago #

    I'm having the same problem following and upgrade to 3.0.4. I don't want to have to reinstall. Have you figured out how to fix this?

  3. James Huff
    Support Team Rep.
    Posted 5 years ago #

    Try manually resetting your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the Twenty Ten theme to activate and hopefully rule-out a theme-specific issue (theme functions can affect the Dashboard).

  4. TonyAwards
    Posted 5 years ago #

    Hi James -- sorry for the late response to your post but I had to attend to some other things, but I've finally gotten the chance to get back to this issue...

    I tried both of your suggestions above with no luck for either one. Renaming both the plugins and the themes directories with .hold added had no effect: I still get a completely blank page at http://mysite.com/blog/wp-login.php, with no fields or page data whatsoever. Strange. The only thing I noticed is that the public site no longer would load anything at all either, no Ten-Twenty theme - just a blank page too.

    Any other ideas...?

    Worst case, if I have to manually reinstall the entire blog, how would I do that safely? I have a dev version of the site locally in lampp but have never been able to get that nor its plugins to update from my linux home box (some weird linux permissions or FTP access issue I've not resolved as yet). And the wp-config.php would have to be adjusted as well, wouldn't it?

    I do have a reasonably current saved database download; after the new installation of WP, how would I then load that into the site?

    Sorry fo the basic (and slightly off-topic) questions but as I mentioned, I'm a bit of a WP and php newbie...

  5. James Huff
    Support Team Rep.
    Posted 5 years ago #

    Try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Some uploaders tend to be unreliable when overwriting files, so don't forget to delete the original files before replacing them.

  6. TonyAwards
    Posted 5 years ago #

    Thanks for the reply, James. I was about to do your fixes when I was given a suggestion to simply eliminate the .php from the standard login url (/wp-login.php) and try that. It worked immediately; I got in, upgraded to 3.0.4 along with several plugins. I logged out and back in to test and all appears to be working fine.

    Also, the normal full login url is now working as it's supposed to as well after doing the abbreviated login that one time.

    Don't know why this made a difference (perhaps you do), but it sure did.

  7. desmillicious
    Posted 5 years ago #

    Hi guys, I had the similar problem but none of these fixes helped.

    In the end I got in contact with my hosting provider (bluehost) and they informed me it was a permissions issue.

    Several folders had permissions set to 777 and needed to be reset to 755 and files to 644.

    I hope this helps some.

Topic Closed

This topic has been closed to new replies.

About this Topic