Support » Networking WordPress » Upgrade to 3.0.2 … Now I can't save posts.

  • Hello.

    This morning I upgraded my WordPress Multi-Site Network install from 3.0.1 to 3.0.2. The upgrade went smoothly.

    The front-end of the site works perfectly. The back end… not so much. I can no longer make any posts or pages on any of my multi-site sites. Clicking on New Page or New Post gives me the edit form, which I fill out. If I hit “Publish” or “Save Draft” I’m redirected to /wp-admin/edit.php, which displays the “list” of pages/posts without having saved my content.

    This happens in Chrome and Opera, and isn’t a stale cookie issue (as I’ve deleted cookies, just for luck, and re logged in).

    I’ve deactivated all plugins except for the Webcomic plugin, as that plugin MUST be active for the site to be worth paying money to host.

    EDITING a page or a post works exactly as expected.

    Any pointers where to go from here? My sites are now completely halted as I can’t post any new content…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Try doing a manual upgrade?

    Also … it may be the WebComic plugin. I know it needs to be on, but for a test, turn it off (just for 5 minutes) and see what happens.

    OK, I nuked all plugins for 10 minutes and cleared my APC cache. Made for a very boring site, but in either case, everything off and APC refreshed did not bring back my ability to post.

    FWIW, I tried making a post with Firebug enabled. I see that clicking “Save Draft” calls /wp-admin/post.php

    Which responds with
    Failed to load source for:

    The only posts I’ve seen that discuss this talk about apache mod_security… which would be fine if I used apache, which I don’t. The server runs Cherokee over FastCGI, so now I’m just more confused.

    /wp-admin/post.php does exist… and it has a default at the bottom to redirect to ‘edit.php’ if no action is defined when calling post.

    …no action is defined when calling post hitting the Save buttons on the editor screen.

    Don’t know if this is a bug, bug, or some weird piece of my server, but that seems to be it. Saving from that page doesn’t tell post.php what to do, so it just blindly redirects to edit.php

    Can’t do any more research right now.

    Failed to load source, the last time I saw it, was an .htaccess error. But you’re not using apache, and I’m not 100% sure how that works for your set up.


    I’m really not a happy camper about this. I’ve now burned > 5 hours just tracing through code trying to figure out why something which worked as expected a few weeks ago wasn’t working at all now.

    I’ve found one looks like a bug: /wp-admin/edit-form-advanced.php sets the “action” hidden value to editpost by default, and because of that, the check_admin_referer function chokes, as the form is coming from post-new.php, not an “edit-” file. Putting in some hacks to allow post-new.php to

    $form_action = 'post';

    And then make edit-form-advanced.php check for a pre-set value

    if(!isset($form_action)) { $form_action = 'editpost'; } // HACK! HACK! HACK!!!

    …at least changed the error from “silently dumps you out to gives you an error message that your post could not be posted.” Helpful.

    There’s also a redirect issue. My WordPress network contains 2 sites, a webcomic site and a blog. Both of those sites you can post posts and pages to… it’s just that the redirect is broken, so it dumps you to the post listing, which was causing me to believe the posting wasn’t working (as that was what I was seeing on my latest-and-greatest site #3). So at least I can make my scheduled updates. I can’t look into why the redirects consistently redirect you to /wp-admin/edit.php even when posting a new page right now, but posting a page successfully should redirect you to edit.php?post_type=page

    Sites are silently failing to save drafts. If you click “Save Draft” you get redirected to edit.php, with no draft saved. Why? Don’t know, my brain’s hash.

    However, even more exciting, creating a new blog under 3.0.2 throws a 500 error; the blog ID is insterted, and a handful of tables are installed… but not the full compliment. And all the issues above stem from there not being a _posts table for the new blog I created after updating to 3.0.2, and therefore there being no place to put anything.

    TL;DR: I need sleep, periods are turning into semicolons and I can’t focus. Any suggestions on what to actually look for and debug to figure out why would be nice. Cherokee isn’t even adding anything useful to the error log, so hurray. I get to “add a zillion prints and dies to find where it keels over” and I’m not up to that without some sleep.

    I’ve asked around, but alas, I cannot find anyone with Cherokee so … 🙁 I think it’s a WP vs Cherokee conflict, since no one else with that plugin (and there are a LOT of ’em … I love web comics) are reporting this issue.

    I would raise a ticket in trac at this point.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Upgrade to 3.0.2 … Now I can't save posts.’ is closed to new replies.