WordPress.org

Support

Support » Installation » [Resolved] Upgrade to 3.0 problem: can’t edit pages from Dashboard

[Resolved] Upgrade to 3.0 problem: can’t edit pages from Dashboard

  • I’ve just updated to 3 and I can’t get into Edit Pages or Add Pages. The message I get is:

    The requested URL /wp-admin/edit-pages.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    My website is still available on the web but I’m unable to update my site.

    Any solutions available?

Viewing 15 replies - 1 through 15 (of 36 total)
  • try wp-admin/edit.php for posts
    &
    wp-admin/edit.php?post_type=page

    for pages

    Delete the wp-admin folder and re-upload it from a fresh 3.0 copy. I think some files didn’t get updated correctly.

    I am having same the issue, when logged in as the admin you can get to the pages by clicking from the 404 to the actual pages that you are trying to edit. While logged in you can see the edit button on the page and when you click that you can edit. The real problem is that you cannot edit from the dashboard. I have tried reinstalling the version 2 times, as well as deleting the admin folder and copying over, as well as a clean upgrade according to this page http://codex.wordpress.org/Upgrading_WordPress.

    I’m having a similar issue where I can access the pages, but not the posts or custom post types (displays a 404 error). Disabling the plugins, using the default twenty ten theme, re-uploading the wp-admin files, and re-installing the whole version didn’t fix the issue. It seems like it’s a server and/or database related issue at this point (due to lack of other options that I’m aware of), but it’s a site that was running 2.9.2 without any problems before the upgrade.

    I’ll keep this topic bookmarked if I (hopefully) come across a fix.

    I had the same problem and found that the All in One SEO plugin was causing it. Working fine now.

    Any suggestions? Like KZeni I can’t access Posts to edit from dashboard. This 3.0 is a huge pain!

    brianrho, I disabled the All in One SEO and the CMS plugin and that took care of the issue, it appears that those having the issues just need to go through one by one with the plugins and do some testing and then notify the authors of the plugin issues. KZeni I switched over to TGFI.net SEO and it allows me to populate titles of pages as well, although I do like using the All in One SEO as well.

    Since upgrading to 3.0 the dashboard appears but plugins, google analytics, wordpress news etc, are in a permanent state of loading.

    I can’t access anything whatsoever, clicking on pages, plugins or anything at all just goes to “Internet Explorer cannot display the webpage”.

    Any ideas?

    same problemmmm…

    Betelguese – Rename the plugins folder to plugins-old. You may have a plugin not compatible with WP 3.0

    Same here. I deleted the wp-admin folder and re-uploaded it but it still doesn’t work.

    Specially, the edit.php and upload.php don’t work (but post-edit.php does). Possibly others as well.

    Sounds like a bad install. Delete wp-includes and reup that.

    I too just upgraded to 3.0 and have been unable to access my dashboard. It is there – I’m not getting a 404 error like others – but its blank and I am unable to do . . .”admin” things like posting, edting etc.

    Thus far I’ve re-loaded a clean copy of the admin folder – nothing changes.

    I don’t have any SEO type plugins, or analytics type plugins.

    I can navigate the site, and leave comments. It recognises that I’m logged in – but again no access to dashboard.

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    I found in my case that the excellent plugin DB Cache reloaded was the cause.
    After deactivating it I was able to access Edit Posts.
    I am under the impression that this is an incompatibility issue between 3.0 and cache plugins.

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘[Resolved] Upgrade to 3.0 problem: can’t edit pages from Dashboard’ is closed to new replies.