Support » Installing WordPress » Upgrade to 3.0 Fails

  • Resolved ronblaisdell

    (@ronblaisdell)


    Receiving the following error message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2964967 bytes) in /home/content/…/html/wp-includes/http.php on line 1363

    And the upgrade process stops.

    Any ideas other than doing a manual update?

Viewing 15 replies - 16 through 30 (of 40 total)
  • To people who want to know where to post the

    define(‘WP_MEMORY_LIMIT’, ‘256M’ );

    statement in the wp-config.php file, you can put it anywhere. It is a file that has definitions. You can put it anywhere in the file.
    I just put that for my site
    Short Articles and it works like a charm.

    thank you SO much for that plugin, nacin! installed it and it worked like a charm! you saved a bunch of headaches for a wordpress amateur.

    youradu: To be fair, it needs to be before the line that says “That’s all, stop editing! Happy blogging.”

    revivetv: Glad we could help!

    since i have upgraded to version 3, i cant upload or install new themes or plugins, i cant even upload wordpress version 3 again, i get this message -Incompatible Archive. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    I’m where you are… I’m in the middle of a failed upgrade.
    What to do from here?

    I’m with Fendeanson, did the plug in and no go. Still at downloading zip, or that is what dashboard says. I have two hosts, on one it installed fine, on 1and1 it didn’t, so there is something different there. Most likely permissions and not memory, but there are no errors either, which is bad, there should at least be a timeout error.

    I had the same problem (stuck at downloading…). I’m on 1&1. The plugin did not work. The problem turned out to be that 1&1 defaults to PHP4 instead of PHP5. I found the fix here: WordPress on 1&1

    Only a couple of my users are reporting problems with the wordpress 3.0 upgrade.

    One of my editors always gets the error message

    Fatal error: Call to undefined function is_multisite() in /home/site10/public_html/wp-includes/wp-db.php on line 505

    I’ve tried adding define(‘WP_MEMORY_LIMIT’, ‘256M’ ); to my wp-config.php

    tried http://wordpress.org/extend/plugins/memory-bump/

    this really sucks that I am stuck with people unable to login

    I was getting this issue too with 1and1 hosted sites:

    In my case when i clicked the upgrade link from wp-admin i got a 500 error from 1and1.

    Error 500 – Internal server error An internal server error has occured! Please try again later.

    Things i tried:
    – disabled all plugins (didnt work)
    – I added the plugin for memory (didnt work)

    This method did work for me:

    Added “AddType x-mapp-php5 .php” to the .htaccess (in the main wp folder) file right before the </IfModule>, Saved and then clicked the upgrade link again.
    Worked like a charm.

    Just had to do a db update when the screen promoted me to. I think this is standard with the upgrade though.

    Hope this helps people that are still having issues.

    -estern

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    vboogieman, most people report that a manual update fixes this.

    For estern23, thanks for your advice. I am with 1and1 and it just gets stuck on the downloading screen. I have tried the memory bump plugin but did not have any result.

    I am interested in trying your technique but can’t find the .htaccess file. I am using a theme – is this why?

    If you can tell me how I get to that folder I would be most grateful,

    Thank you very much,

    Jon

    Did what Alwaysworking01 advised. and it worked!!

    1. PRIOR to upgrading to 3.0 first do the below.

    2. Deactivate all plugins, install the “MEMORY BUMP” Plugin http://wordpress.org/extend/plugins/memory-bump/

    3. Activate it, and then activate all other plugins, takes about a minute.

    Thanks Birdnesty

    Unfortunately I am still having trouble. I have deactivated all my plugins except the memory bump plugin. I click on Automatic Upgrade and after a few seconds it just freezes.

    Perhaps it’s because of my theme?

    Anyway, thanks for trying to help. Does anybody else have any other ideas or the same issues?

    Thanks,

    Jon

    Another thing I could try is by manual install. However, as I am new at this, I don’t now how to install it with all my existing content – I do not want to re-do all my posts.

    Any advice would be greatly appreciated.

    Jon

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    cashalerts, follow this guide to do a manual upgrade.

    http://codex.wordpress.org/Upgrading_WordPress_Extended

    If you do it right, you won’t lose any content.

Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘Upgrade to 3.0 Fails’ is closed to new replies.