WordPress.org

Support

Support » Installation » [Resolved] Upgrade to 3.0 Fails

[Resolved] Upgrade to 3.0 Fails

  • Receiving the following error message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2964967 bytes) in /home/content/…/html/wp-includes/http.php on line 1363

    And the upgrade process stops.

    Any ideas other than doing a manual update?

Viewing 15 replies - 1 through 15 (of 40 total)
  • Not unless you can allocate more memory to PHP. It’s the size of the upgrade, IIRC. They’re working on trimming it down, but not every host is happy with it.

    I got the same error on the same file on the same line number doing the automatic upgrade. Hosting on 1and1.com. I had to resort to upgrading the old fashioned way and that worked.

    I am hosting one 1and1 too. I’m running RC3 and when I tried to upgrade to 3 it just gets stuck at the “downloading .zip file” step.

    same here =(

    I’m thinking this must be a bug in RC3… either that or a problem with 1and1.

    I’m on 1and1, but I’m pretty sure I can change the allocation. What lines in what file do I have to change to what amount in order to have enough memory for the auto install?

    I had the same error on one of my updates. I tried disabling all of my plugins and the auto-update worked flawlessly.

    Okay, found a solution for 1and1 hosting:
    1. Create a file called php.ini
    2. Put this text in it: memory_limit = 64M
    3. Save it and upload it to the /wp-admin directory.

    Now you should be able to do the automatic upgrade.

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    We’re in the process of pushing out a plugin for this: http://wordpress.org/extend/plugins/memory-bump/

    In the meantime, you can also add this to your wp-config.php file:

    define('WP_MEMORY_LIMIT', '256M' );

    The issue is that WP *may* need more than the default 32 MB to upgrade to 3.0, due to the increased package size over 2.9. This is a “known issue”.

    3.0 handles this by always bumping you to a very high memory limit in the admin area, so you won’t see this once you’ve hit 3.0.

    Nacin If you would please, cause I know you all have your brains together on things 🙂 Please tell us where to put the define(‘WP_MEMORY_LIMIT’, ‘256M’ );
    On the phone with IX now trying to resolve this so our other blogs don’t have the same goat rope.

    Thanks

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    The plugin I linked to is now packaged, so it’ll work: http://wordpress.org/extend/plugins/memory-bump/.

    For the constant, see http://codex.wordpress.org/Editing_wp-config.php.

    FIXED IT!!!

    1. PRIOR to upgrading to 3.0 first do the below.

    2. Deactivate all plugins, install the “MEMORY BUMP” Plugin http://wordpress.org/extend/plugins/memory-bump/

    3. Activate it, and then activate all other plugins, takes about a minute.

    Upgrade to 3.0 and it works!

    Tried this first without deactivating plugins and it didn’t work.

    Thanks!

    It’s still not working for me. I’m not having errors about running out of memory, the update process is just stopping at the downloading zip file stage. Any thoughts on what this is?

    I appreciate all the information. I am waiting to perform the upgrade until there seems to be a good fix.

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    fendeanson: that might be because your server is hiding errors. If it is hanging at the download, this is almost surely your issue. I will update the plugin description to account for hidden errors making it look like you’re stalled at the download step.

    williemanillie: the plugin *is* the fix, so I would test it out. We’ve known about the potential for this issue when upgrading to 3.0 for a few months now. We mitigated it the best we could and we further prepared for it by readying this very simple plugin.

    Hope that helps.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘[Resolved] Upgrade to 3.0 Fails’ is closed to new replies.