Support » Fixing WordPress » upgrade to 3.0 broke visual editor, need help plz.

  • Resolved martinperreault


    I upgraded to 3.0 from the previous most recent 2.x version.
    Everything seems to have been upgraded nicely. The blog works, etc.
    But the Visual Editor seems broken now.
    Whenever I try to Add a New Post, or even Edit a previous post, the Visual Editor is broken as follow:
    – I click on Add New Post
    – The page loads, and I can see for a brief second the toolbar from the Visual Editor appearing, then it disappears right away.
    – If I type in the Visual Editor, nothing seems to show. If I click on the HTML editor, I can see the text and codes. Clicking back to Visual Editor makes the whole editor frame disappear.

    To solve the issue, I tried (without success):
    – disabling all plugins, tried editor. no success.
    – disabling all plugins, closed Firefox, tried Internet Explorer. No success.
    – disabling all plugins, then re-enabling all plugins, tried editor. No success.
    – disabling blugins, cleared broser cache & cookies, tried editor. No success.
    – disabling my wordpress theme, activating default theme, tried editor. No success. Then re-activating my theme.

    Now, here’s the curveball: I have three wordpress installed on my server. I upgraded all of them to 3.0, from 2.x latest version. TWO of the wordpress have the Visual Editor Broken problem, but the third wordpress is OK (its Visual editor works fine)!! I am totally puzzled.

    What am I overlooking?

    Thanks for the help!


Viewing 7 replies - 1 through 7 (of 7 total)
  • Well, I found out how to solve it, thanks to this post.

    This part solved it for me:

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress

    But just to make sure, before I proceeded to do the above, I manually made sure all plugins were disabled as follow:
    – connecting FTP to the wordpress folder
    – renaming plugins folder to plugins.hold
    – creating a new empty folder named “plugins”

    Once I re-uploaded the wp-admin and wp-includes folder, I logged in WordPress and went to the visual editor, which now worked fine. I then proceeded to delete the empty plugins folder, and renamed the plugins.hold folder back to plugins.

    I hope the above can help someone else in the future.


    Oh man- I had a lot of hope for this fix. I’ve been having this same issue since the 3.0 upgrade.

    Unfortunately, after replacing wp-admin and wp-includes, I’m still unable to see the visual editor in the good old fashioned way.

    Any more ideas?

    I tried what martin mentioned, no joy for me. Anyone?

    Actually, when in “edit a post” I am getting two javascript errors:
    “tinyMCE not defined”

    Error: tinyMCE is not defined
    Source File: http://mydomainname/wp-includes/js/tinymce/langs/wp-langs-en.js?ver=327-1235100
    Line: 1
    Error: tinyMCE is not defined
    Source File: http://mydomainname/wp-admin/post.php?post=737&action=edit
    Line: 1004

    So, this seems like a problem!

    Do any of you having the trouble use Next-gen gallery plugin?

    I broke my visual editor by applying a filter to tiny_mce_before_init in my functions.php file

    …aka adjusting the buttons and styles that showed up on the wysiwyg editor.

    Just a word of caution on that, it’s easy to break 🙂

    No love for me on this…

    I downloaded and installed the plug in for Dean’s editor…

    I don’t have time to troubleshoot this…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘upgrade to 3.0 broke visual editor, need help plz.’ is closed to new replies.