Support » Fixing WordPress » Upgrade to 2.9.2 not allowing Insert Into Image

  • Recently upgraded to 2.9.2. Cannot insert images into post or page whether Uploading it for the first time or selecting it from the Media Gallery.

    – I choose Add an Image icon next to the Upload/Insert on the Edit Post screen.
    – Flash and Browser Uploads work fine…the Graphics are uploaded and I can see them in Media & Gallery.
    – Then the “Graphic Info” screen (From Computer tab)displays – and this is what is not working. When I click Insert Into Post the page repaints with a 404 error. If I click Save All Changes…it works fine.

    – When I Edit a Post and try to insert an image that is in the Media Gallery using Insert Into Post I get the 404 error upon clicking Insert Into Post.

    In testing
    – I have CHMOD to 777 on wp-content/uploads/ and below – and Insert Into Post still does not work.

    – I have checked the .htaccess so that it looks exactly like it should:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /kathys-blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /kathys-blog/index.php [L]

    – I updated my permalinks:

    – I changed the Setting/Miscellaneous/ Store Uploads in this folder to: wp-content/uploads

    I have tried several of the solutions in some of the [resolved] issues in the forum that have similar behavior – but – I haven’t seen where someone actually had an issue with Insert Into Post upon upgrading to 2.9.2.

    Anyone have a suggestion? Link to a resolution? Help will be much appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    Hey esmi,

    Strange question here I know, but, assuming that the plugins folder is clear/empty etc., assuming that all plugins are deactivated if any there, and assuming switching out the theme for the default fixes this, what could then be the issue with the current theme files?

    If it is in the functions.php file (which I think it might be), what could be the problem to prevent files/images being inserted into a post? How can we find them? How does one find a ctrl character or something that might cause this issue? It’s been driving me crazy and I cannot afford to switch out the theme for the default every time someone wants to upload a file…


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Upgrade to 2.9.2 not allowing Insert Into Image’ is closed to new replies.