Support » Installing WordPress » Upgrade to 2.9 from 2.8.6 fails

  • Upgrade has disabled the admin of my blog

    Blog still loads, but admin gives this error:

    CGI Error

    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    The upgrade.php file gives this error:

    WordPress database error Unknown system variable ‘NAMES’ for query SET NAMES ‘utf8’ made by require, require_once, require_once, require_wp_db, require_once WordPress database error You have an error in your SQL syntax.

    MySQL version is Client API version 5.0.22

    What’s the problem?

Viewing 15 replies - 1 through 15 (of 20 total)
  • That is strange.

    At this end, it requires MySQL version 4.1.2 or higher so it’s the end for me. I have two databases running under 5.0 and 5.1, but no ability to move all the tables.

    Why does still list 4.0 of MySQL required when there seems to be a higher requirement?

    Any solutions?

    Thanks beforehand. πŸ™‚

    @Henrikbunck – Here’s what I did to do a successful WP 2.9 upgrade on 1and1 –

    I used phpMyAdmin to export my database from MySQL4 and import it into a new MySQL5 database. Here’s a step by step with screen shots of what I ended up doing to move the database tables and get a successful upgrade:

    What I learned upgrading to WordPress 2.9

    I hope that helps and can save you some of the hassle that I went through!

    hi there everyone, or anyone.
    am desperate.
    i upgraded from 2.8.6 to 2.9…
    but as a result, my site was put on “maintenance”mode, my widgets disabled, and now the only thing i see is an error message, a warning that the header can’t be modified, etc.
    i can still open my blog, partly, but the plug ins and widgets are not working. i cant get to my admin dashboard as well. am stuck.
    quite frankly, ive invested much time and effort on my blog only to be stuck like this, with no idea if i can even get back to 2.8.6 instead because i cant get anywhere, it just brings me to that same warning message!
    can anyone check out what i mean?
    see my blog
    then maybe you can try going to my admin page, you’ll see what i mean πŸ™‚
    i wonder if i get notified with any answers and help i get from this forum, but just incase, you may email me instead. just put Re: UPGRADE PROBLEM with WP 2.9.

    @patrick – try taking your site out of maintenance mode. FTP to the directory where you have WordPress installed and rename or delete the .maintenance file. Then see if you can log into your Admin and re-activate your plugins.

    If your upgrade failed before the database upgrade was done, you might also try to copy the WordPress 2.8.6 files back over to your installation – just make sure you don’t overwrite your existing wp-config.php file!

    Good luck.

    You can also manually get WordPress to do the database upgrade by visiting upgrade.php in your wp-admin folder.

    So if WordPress was installed in your site root it would be:

    Or if in a directory called blog:

    To others, if you tried to perform the auto-upgrade and it failed (causing you to now see a white screen), the best advice I can give is to upload WordPress via FTP and visit the upgrade URL above (WordPress will also force you onto it if you try to login before the database has had the necessary changes made).

    Im in a similar problem as –patricksan–. I have just started my blog (my blog is in spanish). I forgot to disable the plugins when I upgrade to 2.9 and then i couldnt see anything about my blog because there appered a failure message but i fixed that by changing the plugins/ directory to .plugins/ and then turning it back to plugins/ . Then all the plugins where disabled so i enable them one by one. Then I realized that every time I enable Maintenance Mode plugin, there appears the failure messsage. So I try by deleting it manually and installing by dashboard >plugins >add plugins//// but every time I enable it, the same thing of failure keep happening. I dont know what else to do…
    help me? please.

    @omarmnn – it would seem that plugin is incompatible with your version of WordPress. Have you tried contacting its author?

    OK, lets back to my original question.

    Here’s my error, which happens with plugins enabled or plugins disabled (all plugins)

    wp database error Unknown system variable β€˜NAMES’ for query SET NAMES

    THis error happens when I run the upgrade.php page, and when I click the Upgrade button on that page. I had to revert to 2.8 by re-uploading the 2.8 files (database seems to have gotten nothing done to it, due to the errors)

    I am on PHP 5.2
    MySQL Client API version 5.0.22

    Any ideas?

    Unless you are getting this particular error, please post a different forum message. I am seeking a resolution for the error I specified

    > MySQL Client API version 5.0.22

    Have you checked the MySQL Server version?

    There is an explicit requirement for MySQL >= 4.1.0 to execute the SET NAMES command, and this has nothing to do with the MySQL Client.

    OK,, Server version: 4.0.24-nt-max

    OK,, Server version: 4.0.24-nt-max

    > I don’t see any indication in the php info what version server it is

    That’s correct. MySQL is not part of PHP.

    “That’s correct. MySQL is not part of PHP”

    I knew that— I thought the PHP would know what MySQL server was avaailable to it

    > OK,, Server version: 4.0.24-nt-max

    Well there you go. Your server doesn’t meet the minimum requirement for WordPress 2.9. The only consolation I can offer is that WordPress should have done a better job of informing you of the incompatibility.

    p.s. Since the upgrade never ran, it should be fairly safe to upload the 2.8.6 files back to your server.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Upgrade to 2.9 from 2.8.6 fails’ is closed to new replies.