WordPress.org

Support

Support » How-To and Troubleshooting » Upgrade to 2.7 Connection Troubles

Upgrade to 2.7 Connection Troubles

  • Hi all,
    Today I’ve upgraded a site from v2.5 to v2.7, and now it seems to not keep alive the connection with the database, allocated in another server.
    This message appears sometimes :

    Error 2 (net::ERR_FAILED): Unknown error.

    The DNS are OK, all is ok but the fact is that it doesn’t keep the connection as it used to do in previous versions (2.5)
    Please, I can’t stand this situation long time without reverting to older version, so please can anybody help me?

    Thanks in advance

    Kris

Viewing 12 replies - 1 through 12 (of 12 total)
  • Browser and version you are using on your local machine?

    Web-server on your hosts server?

    Version of PHP on your hosts server?

    Version of MYSQL on your hosts server?

    Browser : latests Chrome, IE, FF
    Web-server: Apache v2.2.6
    PHP v5
    MySQL v5.0

    Thanks

    Most references to the Error 2 I could find did point the Chrome.

    now it seems to not keep alive the connection with the database, allocated in another server

    Any messages that point to the problem as being a database connection issue?

    Any input from your host company about the database connection problem?

    No, there’s no other connection problems, but it’s the only thing i’m capable to think of, due it’s not a regular problem..
    If the connection cut was unreversible ( it couldn’t connect refreshing the browser) then I might think about Session problems..

    Thanks a lot, today i’m going to revert to the previous version.

    Kris

    Hi again!
    I found the errors log and saw a lot of errors like this :
    PHP Fatal error: Maximum execution time of 60 seconds exceeded in D:\\webs\\xx\\xx\\wp-includes\\xx.php on line 1622

    I’ve seen older logs but none had this kind of errors,
    ho or where can I find and change this 60sec timeout???

    Thanks!!

    PHP Fatal error: Maximum execution time of 60 seconds exceeded in D:\\webs\\xx\\xx\\wp-includes\\xx.php on line 1622

    What was the value for the xx in the xx.php above?

    Oh, there’re many :
    post-template.php on line 167
    deprecated.php on line 1056
    widgets.php on line 1622
    post-template.php on line 167

    but the worst is still that message appearing as if the server were down or restarting..

    Some news..
    There’s something that crashes the server’s Apache on this new version 2.7, have any idea?

    I’d be tempted to talk to your host.

    What host do you use by the way–maybe someone else uses them also.

    Well, it’s one of our servers,
    A Windows Server 2003 that hosts both IIS and Apache services with many websites each, i have full control but i can’t damage the other sites nor restart every 5min..
    So I have no other one to ask to these questions.

    but anyway, I need to fix this, and I think that u need it too, at least to know the answer,
    so where do we start? where can i find the differences between v2.5 to v2.7?
    specific needs in Apache or PHP config? does the upgrade modify any of those configs?

    Thanks

    OK,
    for if anyone needs it..
    the upgrade to the v2.7 seems to change some PHP files, maybe its a coincidance, but after reinstalling PHP on the server, wordpress is working, at least for now, i hope for tomorrow too..

    thanks

    the upgrade to the v2.7 seems to change some PHP files

    I don’t believe WordPress changes any files that are part of the files necessary to run PHP.

    If you have any details, please provide them. Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Upgrade to 2.7 Connection Troubles’ is closed to new replies.
Skip to toolbar