WordPress.org

Forums

Upgrade to 2.7 - Can't add new users, new posts, new comments, new pages. (22 posts)

  1. rwang0
    Member
    Posted 6 years ago #

    So I've been going through living hell with this 2.7 upgrade. I made the move and everything is falling apart piece by piece, even after falling the detailed upgrade instructions.

    My current issue at http://blog.softwareinsider.org:

    Can not do the following:
    1. Create a new post
    2. Create a new comment
    3. Create a new event
    4. Create a new user
    5. Create a new page

    I can do the following:
    1. Edit anything that was created before the upgrade

    I'm guessing it could be any of the following and am looking for any input or help.

    1. User access issue
    2. Database permissions
    3. Bug with anything create related

    Thanks in advance for any help!

  2. MichaelH
    Member
    Posted 6 years ago #

    In light of your other threads I'd consider the following:
    1. Deavactivate all plugins
    2. Change to the WordPress Default Theme
    3. Logout of WordPress
    4. Clear browser cache and cookies; clear/delete any folders related to caching plugins
    5. Redo steps 7 and 8 of Upgrading WordPress Extended
    6. Login to WordPress and see if the problems are resolved. If they are resolved, then change theme back to your original theme and try, one-by-one, to activate plugins.

  3. rwang0
    Member
    Posted 6 years ago #

    Michael, thanks. Let's give it a shot!

    R

  4. rwang0
    Member
    Posted 6 years ago #

    Hi Michael,

    I can not set to the default theme. In fact, the current theme is listed as default whether or not i'm on kubrick or not. anyways, in the process fo clearing this out.

    R

  5. rwang0
    Member
    Posted 6 years ago #

    Hi Michael,

    I've gone through the steps and am experiencing the same issues.
    I've validated with the hosting provider that the database is fine as I can perform all CRUD functions directly in mySQL
    I can not interface any create functions from wordpress.
    I am going to change themes to see if this makes a difference.

    R

  6. rwang0
    Member
    Posted 6 years ago #

    Previous issues were done prior to adding any plug ins.
    I'm now going to add plug ins one by one and change the theme

    R

  7. You know, posting for status in a slew of other threads, linking back here, is kind of rude. It borders on spamming.

    This is a Friday after Christmas, and I suspect a vast majority of posters are enjoying time with family (or bored to tears stuck in train stations and airports... or waiting for the power to come back on... Oh wait, I'm projecting). Anyway.

    The theme you are on is NOT Kubrick. Kubrick has the blue header. What error are you getting, trying to set the theme to Kubrick? Your theme is not default, it's just the currently active theme :) If you can't change your theme in your admin section, remove all your other themes via FTP or in unix shell, and IIRC that should kick it back to the default.

  8. rwang0
    Member
    Posted 6 years ago #

    lpstensu,

    thanks. i appreciate your comment and understand your perspective. from my end, the intent was not to spam but hopefully find a resolution to a common problem and hopefully centralize that response so someone else wouldn't have to go through the 55+ posts I have gotten to that don't seem to show a resolution. I figured if someone like me was looking for a link to the solution, it'd be nice to find the right post.

    i think the issue is not related to the theme anymore but more related to interface between post.php and post-new.php from wordpress to the database. Taking any suggestions. It seems to be a common issue and I'm not sure if it's been resolved to date. If you have seen anything, much appreciated if you would let me know.

    Thanks again for your response. Once again, apologize in advance if you think this is spam. It's not. I'm just trying to make it easier for other ppl should I find a resolution.

    R

  9. Regardless of if YOU think it's the theme, MichaelH (who is WAY smarter than I am with wordpress) thinks you should try it, and I agree with him. He knows more :) Please try it. It's a no-harm, no-foul sort of thing. If it doesn't help, well then, we know. A lot of tech support involves doing things that seem stupid and unrelated (rebooting in Windows to solve 99% of problems). But we trust the more experienced people.

    About the other threads - If people searched before opening new threads, you'd be right. A lot of time they don't so having a separate thread actually makes it easier to find things. Also, your issue appears to be FAR more widespread that just the post/post-new issue.

    So to recap.

    You did everything MicahelH asked except for deactivating your theme. If you can't do that, then there are more issues than JUST the posting, so please, try to change that theme, and report back with the complete error message you're getting if you can't :)

  10. rwang0
    Member
    Posted 6 years ago #

    lpstenu,

    Yes. I have followed his advice. The only thing I couldn't do was deactivate my theme to the default. any suggestions there to deactivate my theme. very appreciative as you guys are the gurus.

    thanks for the other perspective on other posts.

    my workaround that i'm testing right now is probably to go create a new blogger account. set up a whole bunch of draft posts and suck it in. Then i'll just edit them till i fix the issue. ugh.. what a workaround.

    R

  11. MichaelH
    Member
    Posted 6 years ago #

    If you don't have the default theme then upload that from the distribution available via the Download tab above.

    That will be the wp-content/themes/default folder.

  12. rwang0
    Member
    Posted 6 years ago #

    Hi Michael,

    Thanks for yoru response. I can load the default theme. I have, the only issue is that when i look at the theme select options, it always states I'm running the default, regardless of what the actual theme is. Will that impact what happen?

  13. MichaelH
    Member
    Posted 6 years ago #

    The default theme looks like this:
    http://codex.wordpress.org/Image:default1.png

    So assuming your are uploading files into the correct folder, have to guess you have something in your wp-config.php file that is controlling where your WP_CONTENT_DIR or TEMPLATEPATH is.

  14. rwang0
    Member
    Posted 6 years ago #

    Michael,

    Thanks. looking at my current c ode in my wp-config.php here it is with security info masked in ***

    <?php

    // ** MySQL settings ** //

    define('DB_NAME', 'db******_wp'); // The name of the database

    define('DB_USER', 'db******'); // Your MySQL username

    define('DB_PASSWORD', '********'); // ...and password

    define('DB_HOST', $_ENV{DATABASE_SERVER}); // 99% chance you won't need to change this value

    define('DB_CHARSET', 'utf8');

    define('DB_COLLATE', '');

    // Change each KEY to a different unique phrase. You won't have to remember the phrases later,

    // so make them long and complicated. You can visit http://api.wordpress.org/secret-key/1.1/

    // to get keys generated for you, or just make something up. Each key should have a different phrase.

    define('AUTH_KEY', '******** ******** ******** ******** ********'); // Change this to a unique phrase.

    define('SECURE_AUTH_KEY', '******** ******** ******** ******** pgqha7cX'); // Change this to a unique phrase.

    define('LOGGED_IN_KEY', '******** ******** ******** ******** fNLuicT8'); // Change this to a unique phrase.

    // You can have multiple installations in one database if you give each a unique prefix

    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the

    // chosen language must be installed to wp-content/languages.

    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'

    // to enable German language support.

    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    if ( !defined('ABSPATH') )

    define('ABSPATH', dirname(__FILE__) . '/');

    require_once(ABSPATH . 'wp-settings.php');

    ?>

    Hope this helps.

    R

  15. MichaelH
    Member
    Posted 6 years ago #

    Then can only guess you aren't uploading files for themes into the correct folder cause as I said before, the default theme looks like this:
    http://codex.wordpress.org/Image:default1.png

    Might look at:
    http://codex.wordpress.org/Themes#Adding_New_Themes

  16. rwang0
    Member
    Posted 6 years ago #

    Michael,

    thanks again. all themes are located in wp-content/themes. I can use any theme that's loaded. the display on the dashboard only displays the default theme regardless of what theme I select. However, I am able to use whatever theme i select as you can tell. It's just not displaying on top as the "current theme" being used.

    Would that have anything to do with access errors.

    Interesting thing I noticed. I can create new links. Just can not create posts, comments, pages, or new users. May be there's something in that statement that would trigger an idea on your end?

    R

  17. rwang0
    Member
    Posted 6 years ago #

    So here's an interesting twist. If I add a post in the SQL Database, it shows up in the wordpress console. I apparently can not add a post from WordPress, but can work around it by creating SQL Row Inserts.

    Any ideas?

    R

  18. rboatright
    Member
    Posted 6 years ago #

    R,

    DELETE all the folders in wp-content/themes

    (after making a backup.)

    Then, upload the default theme.

    When you get to the appearance screen in wp, it will tell you that it can no longer use XXX theme because the files are gone, and it will revert to the Kubrick theme that is the "default" theme, not the one you have set.

    Try that please.

    Also, I would strongly suggest that you try REMOVING from the wp-contents/plugins folder any plugins you have in there, don't just turn them off, delete them. (after making a backup)

    Then see what's what.

  19. rwang0
    Member
    Posted 6 years ago #

    Thanks. I will try that again and see what happens. I appreciate your response!

    R

  20. One possibly stupid question - How did you upgrade to 2.7? Did you use the core-update plugin or was it a manual copy-up?

  21. rwang0
    Member
    Posted 6 years ago #

    Hi lpstenu

    I downloaded 2.7. I deleted all files as suggested in the detailed upgrade steps and kept the config file. I then got the database test. Then I moved from there to add and activate each plug in and theme one by one.

    R

  22. rwang0
    Member
    Posted 6 years ago #

    Hi.. final solution for those who want to know...

    Gutted the previous environment. Removed unused widgets
    Started from clean install.

    Now on WordPress 2.7 with Atahualpa 3.17.
    Fresh install. No issues.

Topic Closed

This topic has been closed to new replies.

About this Topic