Support » Installing WordPress » Urgent: upgrade to 2.3.3 and entries disappeared

  • Resolved Moominmama


    Hi all–
    I did a manual upgrade to 2.3.3 — adding all but the wp-content folder — and then hit the upgrade.php address. Said all was good, went to the front of the blog and my entries, comments and pages are gone.

    I can’t figure out how to get the database to repopulate the blog — any ideas? I’m on bluehost, if that’s a help.

    So frustrating. The move to bluehost was not without its nightmares and I finally had the blog running smooth. Rats.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I did a manual upgrade to 2.3.3 — adding all but the wp-content folder
    …and you didn’t touch the wp-config.php file, either, did you?

    Are you sure this blog is connected to your old database? It seems as a brand new DB with 1 post, 1 Page.

    Don’t do anything panicky! Just check…

    It is and it’s worse. My whole database contents are gone. At least all the comments are gone. Which means the entries are probably gone. And no I didn’t back up today.

    I don’t understand why this happened.

    I feel kinda sick.

    More weirdness — my wordpress is in wrdp3 but most of the tables are appened wp2_

    I think this has something to do with the bluehost nightmare when I first moved my (seven years worth of blogging) over to a new server.

    Sorry to hear that but every upgrade instructions strat with the sentence BACK UP YOUR DATABASE… just in case something goes wrong.

    I hope you have a few days old backup or that your host makes regular backups and you can obtain it from them. (In a way it is better to lose a few days posts than a whole blog…)

    Check again carefuly the database(s), all the tables etc.

    I do have a backup of less than a month ago but I’m still wondering why it overwrote the entire database. I’ve upgraded a zillion times before and never had to reinstall a database (made me cocky enough not to back up this time — stupid I know).

    Any idea why it would overwrite the database? It’s like it sent it back to scratch or something. There are some very very very old tags in the DB but nothing new. (I think they’re tags from before WP bundled tagging into their installs.)

    I can recover old posts (and maybe even old comments) from rss feeds but I’m still totally freaked out about how in the hell this happened. Any guesses?

    The only thing I can think about – you’ve run install.php instead of upgrade.php, by mistake. That would result in a complete overwrite…

    You mentioned earlier different databases and/or different table prefixes. I change in the prefix would also result in a brand new install (i.e. creating new tables with the new prefix)

    I definitely did upgrade.php because I typed update.php by mistake the first time. The prefix change — I tracked back — was not an issue. I’ve dumped the whole database backup (from a month ago) into mySQL and am now trying to figure out how to repopulate the blog.

    I hate being a cautionary tale.

    I am still confused about what you did. The blog that is visible at the URL you gave above displays its initial post as made on Jan 14 – which, usually, reflects the date of the installation.

    I know, moshu, it’s the most bizarre thing ever. Here’s what I did play-by-play:

    1. Downloaded and unzipped update.
    2. Opened my account via FTP.
    3. Took wp-content out of update files.
    4. Copied the rest of the files over.
    5. Went to upgrade.php
    6. Checked front page and saw site was gone.
    7. Edited “Hello” post to let folks know what was happening.

    Then I went into my databases and confirmed that all the content is gone. I’ve used bigdump.php to put the gzipped back up into the database but can’t seem to get them to populate throughout my blog.

    but can’t seem to get them to populate throughout my blog

    Sorry, I dont get this. Once the database tables are there and the WP install’s config file is pointing to the right Db+right prefix… there is nothing to do “to populate”. It just should work.

    I know. But then upgrades aren’t supposed to delete entire databases either. I just tried importing the old database into my locally hosted wordpress sandbox and it’s the same thing — it won’t see the entries.

    I may just have to say to hell with seven years of archives — I have no idea what the alternative is.

    Zip that backup file and send it over to my-name-here AT transycan DOT net.

    Thanks Moshu! I did get it back up and I’ll tell people what I did so that I can mark this resolved. (Although I don’t think it’s a resolution people will love!)

    1. I deleted the blog and dumped my tables (they were mostly empty anyway) and then reinstalled wordpress from scratch.
    2. I actually did this several times importing my old entries to the new database via bigdump.php. Each time my blog wouldn’t see the entries so I finally just started over.
    3. Since my old blog installation on the old domain didn’t have an export feature I know that bigdump.php was the only way to get 40 freakin’ megs of entries in seeing as how my backup from January 7th was a .sql file.
    4. I installed wordpress on my Mac desktop with mmap tried dumping my entries into my local mySQL databases, which worked. My locally hosted blog could see the entries!
    5. My locally hosted blog also has export so I exported the files.
    6. I broke the enormous .xml file into about nine parts using this guy’s advice. I also upped the php.ini to allow the full 50 megs but this still timed out so I went ahead and broke it up.
    7. For content posted between 1/7 and now (because my last backup was 1/7) I pulled from my livejournal crossfeed. I lost the comments but kept the content so I’m feeling like a winner.

    I think my blog archives are too big. I think that in a few months I’m going to maybe create an archival blog and start over.

    I appreciate the support, Moshu!!!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Urgent: upgrade to 2.3.3 and entries disappeared’ is closed to new replies.