Support » Installation » [Resolved] Upgrade to 2.2.2 goes haywire

[Resolved] Upgrade to 2.2.2 goes haywire

  • I did the routine upgrade to version 2.2.2 but something has gone wrong. I’ve upgraded before with no trouble. I followed all the upgrade instructions EXCEPT backing up all my files. 🙁

    After upgrading I tried to run the upgrade script but it told me I was already using the most current version. My blog appears okay except when trying to write a new post. Where I used to see the upload images area I get the following message:

    Not Acceptable
    An appropriate representation of the requested resource /blog/wp-admin/upload.php could not be found on this server.

    I tried deleting and reuploading the wp-admin folder. I then deleted and reuploaded all files. I then deleted the original downloaded upgrade files, redownloaded them fresh and did it all again. Same problem. I also noticed that after deactivating all my plug-ins before the first upgrade, they are all listed as activated without my activating them, yet wordpress is treating them as deactivated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • whooami



    sounds like mod_security

    IF YOU DO NOT HAVE an .htaccess in your wp-admin/ directory:

    create a text file on your desktop:

    put the following inside it:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    save the file. name it whatever you want

    Upload the file to your wp-admin directory.

    Rename the uploaded file to .htaccess (with the .)

    IF YOU DO HAVE an .htaccess in your wp-admin/ directory:

    Edit it, and add the following:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    save the new .htaccess

    see if that helps.

    Thanks. I tried that but it makes the entire admin area of the blog inaccessable.

    Then you must have done something wrong, sorry.
    I had the same/similar issue on a blog I manage and the above code in the htaccess file placed in the wp-admin directory solved it.

    I didn’t have an htacess file before. I use a custom template put together by my website programmers. Does that matter?





    I have to agree with moshu..

    the way thats written above it wont spew an error, even IF mod_security isn’t the problem, since it’s wrapped in the <IfModule ...> tag.

    In other words, its only applicable, if its (mod_sec) installed, if its not, it does nothing

    I tried it again, and this time it worked fine. I think the problem was I did not save the file as a plain text document, so I suspect it was saved as a rich text document by default. WordPress must not like that.

    Thanks very much!!! I greatly appreciate the help!

    Nobody likes that!
    You should never ever edit any code file (php or html) in a stupid word processor. Only plain text editor!

    Uhhh. I just read that the htaccess file might have been there but been invisible to my FTP program (Fetch on a Mac). Did I just overwrite my htaccess file and destroy my permalinks info?




    Any .htaccess that existed inside your wp-admin directory did NOT contain anything that WordPress generated.

    So no.

    You are not reading carefully – that might be one of your problems. We are NOT talking here about the htaccess file at the WP root (the one that helps you with nice permalinks!) – we are talking about a 3-lines file INSIDE the wp-admin directory. Don’t mix things…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Upgrade to 2.2.2 goes haywire’ is closed to new replies.
Skip to toolbar