Support » Installing WordPress » Upgrade to 2.2 – Dashboard not working

  • Resolved pacq

    (@pacq)


    My blog is running on MySQL 4.0, phpMyAdmin 2.7.0.

    Hello,

    after the upgrade from 2.1.3 to 2.2, the dashboard doesn’t show the ‘Other WordPress News’, ‘WordPress Development Blog’,
    and the ‘Incoming Links’, but a ‘Forbidden’ message.

    The server error log shows the following:

    mod_security: Access denied with code 403.
    Pattern match “!(^application/x-www-form-urlencoded$|^multipart/form-data;)” at HEADER(“Content-Type”)
    [severity “EMERGENCY”] [uri “/wordpress/wp-admin/index-extra.php?jax=incominglinks”]
    (…) [uri “/wordpress/wp-admin/index-extra.php?jax=devnews”]
    (…) [uri “/wordpress/wp-admin/index-extra.php?jax=planetnews”]

    My server is running MySQL 4.1.20 and phpMyAdmin 2.8.2.4.

    Any ideas? Thanks.

Viewing 15 replies - 31 through 45 (of 55 total)
  • The first-mentioned modification to the .htaccess file did fix the Dashboard feeds problem and the “can’t load this page” problems with saves, but I still cannot publish a new post.

    Hmm, just double-checked my dashboard, and it says the post I’ve been trying to publish is scheduled in 10 hours!

    I had to go into file manager from the cpanel, change the chmods to 755 and edit from file manager to make that change.

    I have not tried the ‘file’ modification yet to see if that will fix the publish problem.

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    The comments seem to work fine, even before the .htaccess modification.

    Whoa, thanks for all the advise. My panic is subsiding.

    Rene

    New post I thought I had a problem with, did publish, at the time specified.

    So the publish problem is also solved.

    I’ve just installed WP 2.2 on my host http://www.haveklummen.dk. No problem while installing. Now when I log into the site as admin, I get the same error mentioned in this thread:
    “You don’t have permission to access /wp-admin/index-extra.php on this server.
    Apache/1.3.36 Server at haveklummen.dk Port 80″.

    I have tried the trick with .htaccess, saved it on the host in the right format, but I just get an error 500, database error, when I upload .htaccess file to my host address. All the file permissons are set to 644. Ive read a lot of support pages without finding any other solutions. I dont have direct access to MySQL database from home, due to firewall restrictions at my webhost provider.
    I’m very new to this – has anyone a good answer to my problem??

    Sincerely
    Jan H. Clausen

    I also get a 404 error where the index-extra.php error was before after following your .htaccess instructions. Any clues?

    Anyone have a clue??
    /Jan

    Had similar issues to this – Except using stock FedoraCore6 box and Mod_security2, Brayne’s (see above) fix worked, but you have to alter modsecurity_crs_30_http_policy.conf from

    SecRule REQUEST_HEADERS:Content-Type “!(^$|^application/x-www-form-urlencoded|^multipart/form-data|^text/xml)”

    to

    SecRule REQUEST_HEADERS:Content-Type “!(?:^(?:application/x-www-form-urlencoded$|multipart/form-data;)|text/xml)”

    Windy

    Hi,

    The .htacess solution to not work for me.

    I would like to try

    # Only accept request encodings we know how to handle
    # we exclude GET requests from this because some (automated)
    # clients supply “text/html” as Content-Type
    SecFilterSelective REQUEST_METHOD “!^(GET|HEAD)$” chain
    SecFilterSelective HTTP_Content-Type “!(^$|^application/x-www-form-urlencoded|^multipart/form-data|^text/xml)”

    However, I do not know which modsecurity file to modify. Is it this one: modsecurity_crs_10_config.conf or to I place it in http.conf?

    Also, is the above for mod_security 1.x? How should it be written for 2.x?

    Also, would you know why the .htaccess method does not work?Is there a setting somewhere that prohibits .htaccess from modifying the modsecurity settings?

    I am getting the same thing .. .htaccess did solve some of the problems .. but I still cant edit or delete posts…

    this is a fresh install today

    I pray that someone comes up with a solution that newbies can use to fix this (or better yet, WP create it and call for a new upgrade – because now my blog is useless to me).

    Never had a problem with upgrades until 2.2.1 and now my blog won’t let me have my admin privileges, just the FORBIDDEN thing no matter what.

    Help for newbies?

    Update to my yesterday’s post…

    I tried Deerhunter’s alteration of the .htaccess suggestion by whooami and put it inside wp-admin just as instructed… lo and behold! Everything works FINE…

    Thank you ALL so much for your amazing brains and solutions, too! Bless you for the simplicity of that solution, too.

    Here’s the exact .htaccess code I put in wp-admin:

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    And that’s all it took… no other tedious or time-consuming editing.

    Have a great 4th if you celebrate, be safe…

    Donna

    I seem to have to keep adding the code…

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    ….over and over again. When I add it and upload it, it works but then later it doesn’t and when I check the .htaccess file it seems to be gone. Any idea?

    When I add it and upload it, it works but then later it doesn’t and when I check the .htaccess file it seems to be gone. Any idea?

    I found that any changes I wanted to stick in the htaccess file had to be outside of the section for WordPress. Keep your customizations separate from the part of htaccess that WP is always re-writing.

    Just weighing in here to let you know that WhoamI‘s fix worked:

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    The .htaccess file was blank, I created it and added this code. Because I needed to set up clean URLs, I CHMOD’d it to 666, made the permalink structure changes in the Dashboard, let WP edit the file, then CHMOD’d it back to 644 and things are fine now.

    Thanks!!!

    Okay – I too am frustrated. Suddenly, I can not add categories on my installation, and I went ahead and upgraded with the assumption that this would help solve the problem.

    Why would Adding Categories (whether in posts or in link) suddenly stop working? I had it working as little as five days ago…

    I’m having the exact problem with my theme-editor.php which wouldn’t give me permission to edit my theme files. (error “Method not implemented…”)

    Changing the CHMOD manually didn’t work either and the fix provided here failed, too.

    Created a .htaccess with WHOAM’s code (replaced the index-extra with theme-editor.php) and uploaded it to wp-admin folder – blog crashes…

    Everything else works fine, editing posts etc.

    I will let my brother do the modsecurity file change in apache and see if it works. Any help or ideas appreciated though…

    edit:Fixed. My brother deactivated the mod_security for my blogs.

Viewing 15 replies - 31 through 45 (of 55 total)
  • The topic ‘Upgrade to 2.2 – Dashboard not working’ is closed to new replies.