Support » Fixing WordPress » Upgrade to 2.1.1 then no permission to access index page

  • I have been running my blog for over a year. I upgraded from 2.0.5 to 2.1.1.

    Since the upgrade I have no access to index and individual pages. Browser returns the following:

    “You don’t have permission to access /motorsports/ on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request”

    Oodly enough I can access the dashboard and even post a test post that shows up as posted in the dashboard. However I get the 404 on anything except dashboard functions.

    I have added no plugins, changed themes or the .htaccess file before or after the upgrade. I have also deleated and reinstalled with the same lack of results.


Viewing 12 replies - 1 through 12 (of 12 total)
  • As an update, I checked the .htaccess file and it remains the same as before the attempted upgrade.


    As an update: I performed another total reinstall and the problem still remains.

    All dashboard functions are accessible but nothing else is and returns the same error as quoted above.



    4 days and counting!

    You know, I wish I could say I’ve heard the Fat Lady at least warming up if not singing.

    But alas…. nothing but crickets chirping on this problem.

    That’s too bad. “Crickets chirping”. 🙂 Maybe nobody else has the problem.

    One way likely to fix such a problem is to roll back the installation. I believe that there is a database change with 2.0.5 to 2.1.1 (there was when I did it earlier today), so this means the easiest way (that I know) to roll back the database is to empty the new database completely and upload the backup of the 2.0.5 database.

    You would also need to upload a backup of the 2.0.5 program files as well.

    I tried that. Rolled it back to 2.0.5, upgraded to 2.0.7 then upgraded to 2.1.1.

    The problem still persists. In addition I’ve checked allpermission of core file directories and they remain what they have always been, 755.

    Have you tried resaving the permalink structure? Also, I know you stated that .htaccess is unchanged, but it sounds to me like that’s where the problem is. Logically, if you got the site back to its precise previous condition when it was working, and it still doesn’t work, then the problem lies outside of WordPress, perhaps with the host.

    One of our sites has .htaccess files all over the place. The blog, I think, only has one.

    I don’t remember all the permission details. These things can be really frustrating at times. Good Luck!

    As I said I reverted to two previous Vers of WP and the blog was ok. When upgrading to 2.1.1 AGAIN the problem persists.

    The .htaccess file is exactly the same, in fact restored from the original.

    On another note I have another blog under the same domain that was upgraded from 2.0.5 to 2.1.1 with zero problems. At least that is anecdotal evidence the jump from 2.0.5 to 2.1.1 wasn’t the problem.

    You may need to re-save the permalink structure anyway. 😉

    I don’t know the answer to your problem, but please note this:

    Count this as resolved.

    Unfortunately I can’t say why, although upgrading from 2.1.1 to the emergency ver 2.1.2 cleared whatever the problem was.

    Fantastic. Why don’t you go ahead and mark this as [Resolved] in the title, then?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Upgrade to 2.1.1 then no permission to access index page’ is closed to new replies.