Support » Plugin: SearchCloak » Upgrade to SearchCloak 2.0.0 causes site-wide warnings

  • Regarding https://wordpress.org/plugins/searchcloak/

    After upgrading to v 2.0.0, every page in the admin area displays errors like this:

    Warning: array_key_exists() expects parameter 2 to be array, boolean given in ../wp-content/plugins/searchcloak/searchcloak_admin.php on line 48

    Warning: Invalid argument supplied for foreach() in ../wp-content/plugins/searchcloak/searchcloak.php on line 57

    Anyone else seeing this issue?

    Thanks!

    • This topic was modified 5 years, 3 months ago by mookieville.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author firebrandllc

    (@firebrandllc)

    Thanks for the report. Looking into right now.

    Plugin Author firebrandllc

    (@firebrandllc)

    Just uploaded version 2.0.2 which solves the line 57 issue.
    Looking into the admin panel issue

    Plugin Author firebrandllc

    (@firebrandllc)

    We’re not seeing the error on the setting screen, but I put in some checking that should prevent that error in version 2.0.3.

    Let me know how it works out.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Upgrade to SearchCloak 2.0.0 causes site-wide warnings’ is closed to new replies.