WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] upgrade – site OK but dashboard inaccessible

[Resolved] upgrade – site OK but dashboard inaccessible

  • I manually upgraded WordPress to the current version today. (manually because the previous version was very old). The upgrade worked but in an unexpected way.

    Navigating to sitename/wp-admin/upgrade.php yielded a blank page.

    The dashboard is inaccessible. This is what appears in the browser address bar:
    http://sitename.nl/wp-admin/upgrade.php?_wp_http_referer=/wp-admin.

    BUT (happily)
    The site itself is visible, and in source I see that it is version 2.91.

    I’ve never encountered this before on any previous upgrade, and I’m totally stumped. Does anyone have any ideas or suggestions?

    Regards & TIA
    -Me

Viewing 5 replies - 1 through 5 (of 5 total)
  • You may want to check your PHP and/or MySQL versions. If you were using an older version of WordPress, it is quite possibly that it was using older versions.

    Here are the current WP requirements: http://wordpress.org/about/requirements/

    Hope this helps!

    ~Anthony

    @italian
    PHP is at 5.2.6, and MySQL is at 5.0.51a

    Ok, those are definitely fulfilling the requirements for WP. This may sound simple, but I’ve seen similar issues in the past. As you mentioned, you upgrade manually (assuming FTP), have you tried reuploading all of the files again? It’s possible that maybe some files got corrupt on the upload. Just a thought.

    ~Anthony

    @italianst4
    The upgrade was done within the shell.
    wget http://wordpress.org/latest.tar.gz
    then

    tar -xvzf latest.tar.gz
    cd wordpress
    cp $files, $dirs

    renamed wp-config-sample.php to wp-config.php and filled in necessary values ($db_host, $db_name, $db_pass) – in other words a wholly “normal” setup.

    Just to be sure, I re-downed latest.tar.gz and did the procedure once again a few minutes ago in accordance with your suggestion. Sadly I have to report exactly the same result.

    Ah well, at least it’s repeatable.

    My thanks for following up on this BTW.

    SOLVED
    The problem was twofold:
    a) permissions – I looked at another blog setup on the same server and set wp-admin permissions (and files therein) to be the same. Once again, that has never (AFAIK) happened before, but hey, it did this time.

    This resulted in the upgrade.php page becoming visible. Now we’re getting somewhere.

    b) Database needed upgrading…..
    THIS time, upgrade.php emitted the “Database Upgrade Required” message – and, as expected, click “ze button” and we’re back in business.

    I hope this is helpful to someone with the same/similar problem who may be following this thread.

    @italianst4 thanks for diving in on this and – in effect – making me look at things yet again. As is so often the case, an extra pair of eyes was hugely helpful.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] upgrade – site OK but dashboard inaccessible’ is closed to new replies.
Skip to toolbar