Support » Plugin: Simple GDPR Cookie Compliance » Upgrade problems

  • Hi,

    your update is causing problems.. The update process freezes and then time-outs, causing all my plugins to not update, and also the information tab “view details” does not load/show any information, just a white screen.

    Cheers.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author themebeez

    (@themebeez)

    Hello @tezalsec

    Thank you for reaching out. We tried to simulate the issue on our WordPress installation but we failed.

    Unselect the Simple GDPR Cookie Compliance plugin and try to update all other plugins and see if all other plugins are updated. If other plugins get updated, deactivate and uninstall Simple GDPR Cookie Compliance plugin and try installing again.

    Best regards.

    Thread Starter tezalsec

    (@tezalsec)

    Hi, thank you for your response.

    I tried it on some other sites, and had the same issue. Unselecting it while updating other plugins works fine.

    What did worked, was to download the latest zip file and upload to update.. this did not cause a freeze. I’ll have to repeat that on all my sites.

    Another thing I noticed, is that the banner did not immediately appear after the update.. I had to save your settings page to have the banner appear.

    One last thing, could you maybe place the plugin link under settings, instead of in the parent left menu? Cookies is after all a modest subject. 🙂

    Thanks and cheers!

    Thread Starter tezalsec

    (@tezalsec)

    Hi, I am sorry to say, the update seems quite buggy. Now the banner only disappears after accepting PER PAGE, which is annoying to visitors. So after accepting on page 2, and then visiting page 3, the banner still appears on page 3.

    Maybe some architecture error when implementing multisite?

    It also does not appear on homepage, only other pages..

    I am reverting to previous version, and mark this plugin ‘never update’ for now.

    Thanks.

    • This reply was modified 3 months, 3 weeks ago by tezalsec.
    Thread Starter tezalsec

    (@tezalsec)

    I am confused.. older versions also behave that way, showing a cookie per page, and accepting the banner does not stop the banner on other pages on the same domain. So to completely suppress all banners you have to visit all pages and accept on all pages.

    is this intended behaviour?

    • This reply was modified 3 months, 3 weeks ago by tezalsec.
    Plugin Author themebeez

    (@themebeez)

    Hello @tezalsec

    We apologize for all the issues that you have been facing. We have make some changes for the multisite in the plugin. You can read the detail on multisite on one of our forum post.

    Once the cookie has been accepted, the banner should not be displayed on the other pages. No this is not intended behavior. We have tried to simulate the issue on our side, but could not do so.

    So could you please share your website with us? We would like to inspect the issue and fix it for you.

    Best regards.

    Plugin Author themebeez

    (@themebeez)

    Hello @tezalsec

    We need your help. We suspect that you are using a cache plugin.

    If you are using a cache plugin let’s do a simple troubleshoot. Do you mind checking the cache plugin setting & exclude a cookie called s_gdpr_c_c_cookie. Once you exclude a cookie please flush the cache.

    Try browsing the site & please let us know if this works.

    Thread Starter tezalsec

    (@tezalsec)

    Hi, thank you for your efforts.

    You are right, I just tested it, it is being caused by the caching. I am using the Supercache plugin, and when I exclude pages with cookie ‘s_gdpr_c_c_cookie’ in the settings, the issue stops.

    However, I assume you don’t expect me to leave this setting like this? That would mean I would have to stop caching all frontend pages just to get my cookie plugin to work correctly. That would be the same effect as just disabling my caching plugin, as the cookie exists on all pages.

    Should all cookie plugins not account for caching mechanisms? Have other cookie plugins not solved this issue? I would think so, otherwise caching & cookie plugins could never co-exist.

    Thank you.

    Regards,
    Tez

    Plugin Author themebeez

    (@themebeez)

    Hi @tezalsec

    No, we will not ask you to exclude pages with cookie ‘s_gdpr_c_c_cookie’ in the settings forever. Please remove this now.

    Next, can you find a setting where you can exclude javaScript & exclude this public facing javaScript file “simple-gdpr-cookie-compliance-public.js

    Looking forward to your response.

    Thread Starter tezalsec

    (@tezalsec)

    Hi,

    have you tested it yourself with WP Supercache plugin?
    I can not find any setting where I can exclude specific files. I can exclude only urls and cookies.

    Regards.

    Thread Starter tezalsec

    (@tezalsec)

    Hi again,

    I investigated some more, and your mentioning of the file ‘simple-gdpr-cookie-compliance-public.js’ led to me exclude this file in the plugin Autoptimize. This is not excluding from caching, but excluding from optimizing, combining and deferring js files, and that seems to be the solution. 🙂

    Since so many people use the plugin Autoptimize, maybe it is an idea to suggest in your documentation to exclude this js file in that plugin’s settings if people use that plugin or any other js optimization plugin.

    Thank you for your help.

    • This reply was modified 3 months, 2 weeks ago by tezalsec.
    Plugin Author themebeez

    (@themebeez)

    Dear @tezalsec

    Thank you for getting back.

    We’ll include it in our documentation to exclude simple-gdpr-cookie-compliance-public.js JavaScript file.

    Additionally, we are working to find a way to make the plugin work even though the defer javaScript & optimization are enabled.

    You have been amazing :). Again, Thank you for your feedback.

    Thread Starter tezalsec

    (@tezalsec)

    Hi again,

    although the JS deferring issue is resolved, the original issue of this thread remains unresolved.

    The update screen still gets frozen when trying to update, now in the newest version as well. It could be a local issue, but I have never experienced this issue before with any plugin of mix of plugins. There are also no log errors.

    The only way it succeeds is by downloading the plugin and then upload from my local computer..

    PS. are you aware your page ‘https://themebeez.com/plugins/simple-gdpr-cookie-compliance’ does not exist anymore? Are you ending support for the plugin?

    • This reply was modified 3 months, 1 week ago by tezalsec.
    Plugin Author themebeez

    (@themebeez)

    Hi @tezalsec

    Sorry I missed to reply that.

    The update screen still gets frozen

    I don’t think the update issue is related to us. I’m 99% sure about this. We push an update to the wordpress.org plugin svn server & wordpress.org deploys the update to everyone using the specific plugin. In this process, we aren’t directly involved while deploying the update to the end users.

    I usually get a frozen screen while updating plugins in the local host & it can happen to any plugin.

    Please be informed that we are not ending the support for this plugin. This page here is returning a 404 error as we plan to migrate this plugin to our new plugin store.

    Till we migrate everything if you need to discuss or check the status you can do that here.

    I hope this helps.

    Have a great day.

    • This reply was modified 3 months ago by themebeez.
    Thread Starter tezalsec

    (@tezalsec)

    Hi, I am a developer too and I am aware of the workings of the WP updating process, and have never experienced the frozen screen before. I never do local updating, so that is not it. Also, other plugins updates never freeze.

    I am 99% sure it is a code issue, but I am not sure the cause is in your code. It could be in another plugin specifically interfering with yours, or it could be just code conflicting between plugins, that are neither erroneous, but just not playing well together.

    Maybe I’ll investigate further someday, for now it does not have enough priority for me to spend time on.

    Cheers.

    • This reply was modified 3 months ago by tezalsec.
Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.