WordPress.org

Support

Support » Alpha/Beta » [Resolved] Upgrade Problem in RC3

[Resolved] Upgrade Problem in RC3

  • When pointing my browser to upgrade.php after uploading all of the RC3 files, I get the following errors:

    WordPress database error: [Table ‘rprins_wordpress.wp_usermeta’ doesn’t exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = ‘1’

    Warning: Cannot modify header information – headers already sent by (output started at /home/.sacko/rprins/lazyi.net/wp-includes/wp-db.php:102) in /home/.sacko/rprins/lazyi.net/wp-admin/upgrade.php on line 10

    I am currently running 1.5.2. I saw that somebody else had this problem, but it was buried in an unrelated thread, and I thought I would open this one to give it more visibility. If you have any ideas, I’d love to hear them.

    Thanks!

Viewing 15 replies - 16 through 30 (of 32 total)
  • thanks for the advice. Don’t worry…I learned my lesson about backing up long ago. That is the first thing I do now. I’ll try this and see what happens.

    One other thing that can sometimes help: before you backup your database, move files, etc. while logged in go to the Presentation tab and change BACK to the default theme from whatever theme you currently have selected.

    There’s another error.

    WordPress database error: [Table ‘knoizki_index.wp_usermeta’ doesn’t exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = ‘1’

    Warning: Cannot modify header information – headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/pluggable-functions.php on line 217

    Warning: Cannot modify header information – headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/pluggable-functions.php on line 218

    Warning: Cannot modify header information – headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/pluggable-functions.php on line 190

    Thanks for the help. I’ll just leave it for now.

    Wow! Thanks for the great replies!

    @patrickw: I was still logged in (cookie set and all) and did the steps that you outlined and I’m still getting the “You do not have sucifficent privelages” message. I think I might wait until 2.0 goes Final to test this on my main site, but I hope that I can set it up clean on a different part of my site.

    rprins: Have you tried modifying the password in the database? If that doesn’t work then you can always install fresh and import your comments/posts via WP2’s import function.

    Or you can also do it manually with the database. This is what I recommend simply because it imports everything. Here’s how:

    Backup these tables in their own files (as in each table has their own file):

    NOTE: This is from your UPGRADED wordpress install. Just backup the posts comments and such I listed from your UPGRADED WORDPRESS 2 Install. Not the wp1.5 one.

    wp_categories
    wp_comments
    wp_post2cat
    wp_posts

    Assuming you kept the default prefix. Then, open each file (notepad isn’t great, so I recommend Notepad2 from http://www.flos-freeware.ch/notepad2.html.

    Once each file is opened, use the replace function and replace ‘wp’ or whatever the old prefix was and then have notepad2 search and replace ‘wp’ with the new prefix.

    Then delete the ‘wp_categories, wp_comments, wp_post2cat, and wp_posts’ tables from your database and then import each of the modified files back into the new fresh install database.

    This will import your posts/comments/categories and such into the new install with a working password. Your settings will be lost but you can easily fix those via wordpress’s admin interface.

    Hope that helps.

    @partickw: Thanks for that response, I’ll have to check it out later tonight or tomorrow.

    Thanks!

    Yep, no problem. Let me know how it goes.

    As patrickw posted above, the upgrade does seem to work even though you get the error noted. I got a blank page when attempting to go to my blog page, but after clearing cache and cookies was able to get to the site page and the error about the presentation being “broken” (with the default being reverted to) went away.

    I’m just starting to play with it and I like it a lot. Most everything seems to be working OK.

    I did notice that the import page did not list MovableType as a blog to inport from, yet there is an mt.php page in the wp-admin/import directory (along with b2, GreyMatter, and LiveJournal).

    When attempting to run the page (I had to paste: /wp-admin/admin.php?import=mt as the URL), I got the following error returned: “Warning: call_user_func(): First argument is expected to be a valid callback in /home/username/public_html/blog/wp-admin/admin.php on line 97” which is a comment.

    Since I’m pretty much of a noob when it comes to prgramming I have not been able to decipher where the actual error is being thrown.

    @patrickw: Yea, man… I don’t get it. I just did the upgrade again and it worked perfectly. Man, so strange. But, seriously, thank you for all your help, I really appreciate it and I’m sure others do as well.

    I have to check on that, but I think this error can be caused, if you installed wordpress2 and did not only do an upgrade.
    From the Readme:
    1. Delete your old WP files, saving ones you’ve modified
    2. Upload the new files
    3. Point your browser to /wp-admin/upgrade.php
    4. You wanted more, perhaps? That’s it!

    There’s nothing about doing an install. If you did, it creates the admin user (UID 1) and thus your old user is gone and the password is random.

    Just my idea what could cause this. As I said, this must be approved.

    – David (xy77)

    I am in the same boat, upgrade gave me all those errors and now I cannont log in. Site looks ok, but I can’t access the admin “You do not have sufficient permissions to access this page.”

    I am guess the users table didn’t get updated correctly? Also my catergories seem to not be working correctly

    I tried to create a new account to login to and got this error message:

    WordPress database error: [Table ‘mackersl_peterdorsi.wp_usermeta’ doesn’t exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = ‘2’

    When checking in phpmyadmin I can see that there is no “wp_usermeta” table in the DB.

    I am having permission problems after upgrade. (see this post 52806) After the upgrade to rc3 I do not have permission to post or edit.

    While trying to figure out what the problem is I have found an anomoly in the wp_users table. When using myphpadmin I am given this message about the table.

    UNIQUE and INDEX keys should not both be set for column user_login

    Advice please.

    Aaron

    The usermeta error is benign and can be ignored. This is fixed in svn.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Resolved] Upgrade Problem in RC3’ is closed to new replies.
Skip to toolbar