Support » Fixing WordPress » Upgrade Problem

  • Resolved bjohns10

    (@bjohns10)


    I follow the instructions down to the last detail for upgrading – my primary site is working but when I try to run the upgrade script I get the following error page:

    Warning: require_once(/home/bjohns10/public_html/bjcblog/wp-includes/functions-compat.php) [function.require-once]: failed to open stream: No such file or directory in /home/bjohns10/public_html/bjcblog/wp-includes/functions.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/bjohns10/public_html/bjcblog/wp-includes/functions-compat.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/bjohns10/public_html/bjcblog/wp-includes/functions.php on line 3

    I really don’t know what to do now. I’ve tried re-installing(upgrading) and I get the same thing.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You get this message twice on one page?

    It basically is saying that the page you are viewing can’t find the functions.php script that it requires. Let me think……

    Did you delete the WHOLE wp-includes folder first?

    Did you delete then upload all of the root files (except /htaccess, wp-config.php, etc.)?

    Did you delete the WHOLE wp-includes folder first?

    Did you delete then upload all of the root files (except /htaccess, wp-config.php, etc.)?

    First question – yes – I deleted the whole thing – as per the instructions for upgrade.

    Second question – Yes, I deleted all of the root files as well. I did not delete htacess or wp-config files.

    I backed up EVERYTHING – and I actually already went back to my old version and everything works. I then tried again – following the instructions exactly – and this page is what I get. Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Upgrade Problem’ is closed to new replies.