Support » Installing WordPress » Upgrade problem

Viewing 15 replies - 1 through 15 (of 29 total)
  • The only files I didn’t delete were .htaccess and index.php. Should I have deleted either (I uploaded the new index.php over the old one)? If this is the problem, can I delete them now, re-upload the index, and be OK, or do I need to put my back-ups back up?

    Yes, make a backup of that index.php on your local computer but delete from the server, then upload the index.php from WP1.5 pack (this index file is very different from the one you have). The actual index.php. Retain htaccess if you’re not changing the permalink structure.

    Thanks for replying.

    When I initially did the upgrade from 1.2.2 to 1.5 I still uploaded the 1.5 index.php, I just didn’t delete the old one. Still, I just deleted the index.php and uploaded the 1.5 one to be sure, and I’m getting the same error. Any other ideas?

    The actual index.php (that you see on your website) will now get loaded from the theme folder in WP1.5.

    Delete first and then upload.

    I just went into my error log and saw what’s below (like 50-100 times). I am really a novice at this stuff, so I have no idea how to fix what’s wrong.

    [Fri Mar 4 02:13:49 2005] [alert] [client xxx.xxx.xxx.xxx] /editedout/.htaccess: RewriteRule: bad flag delimiters

    then run the upgrade script as mentioned in the Codex.

    So wait, should I delete everything again and re-upload WP 1.5 (which I’ve already done once)? If I do do this, do I delete everything (including .htaccess) except for wp-config.php?

    Sorry, just want to be clear on how to proceed. Thanks so much for your help.

    No need I guess, unless things are not working. You can make a copy of htaccess also (if you like) and delete from server (to be uploaded later when your blog starts to work normal again). Try running upgrade script first, see if it works. If not, all files have not been uploaded properly (also don’t worry about the db, it’s there until you connect to it).

    I just deleted everything, re-upped 1.5, tried to access wp-upgrade and got the same error.

    I’ll try getting rid of .htaccess now.

    WS_FTP won’t let me delete .htaccess. This is screwy.

    Just so you know, when I first uploaded the 1.5 files, I was able to access the wp-upgrade file fine. There was an error thing at the top, but everything beneath it was fine. I ran the upgrade, it said I was good to go, and then I got the 500 error when I tried to access my site.

    What exactly is the error you get? Also in the new upload, did you update your wp-config.php according to your setup?

    Try smartftp or FireFtp plugin for Firefox.

    Also, I copied my entire site to my hard drive before upgrading. I also saved backups of the site and the databases from my cpanel. So I have those available if anyone has any ideas that would require me starting from scratch.

    What should I have done with my wp-config.php? I just made sure it was there before uploading my 1.5 files.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Upgrade problem’ is closed to new replies.