Support » Networking WordPress » Upgrade issue multisite 4.4.10 to 4.5 Duplicate key segmentation fault

  • I am wondering if anyone has seen something like this before. I have a client who did not update their WP multi installation since 3.8. Now I’m trying to bring them to 4.8 after they were hacked (no surprise at all).

    I am stuck at WP 4.4.10, an interim step to 4.5 or 4.6. I’m unable to get past 4.4.10 with a working site, and the only errors I can find are these:

    WordPress database error Duplicate key name ‘meta_key’ for query ALTER TABLE wp_usermeta ADD KEY meta_key (meta_key(191)) made by wp_upgrade, make_db_current_silent, dbDelta

    WordPress database error Duplicate key name ‘domain’ for query ALTER TABLE wp_site ADD KEY domain (domain(140),path(51)) made by wp_upgrade, make_db_current_silent, dbDelta

    WordPress database error Duplicate key name ‘meta_key’ for query ALTER TABLE wp_sitemeta ADD KEY meta_key (meta_key(191)) made by wp_upgrade, make_db_current_silent, dbDelta

    WordPress database error Duplicate key name ‘domain_path’ for query ALTER TABLE wp_signups ADD KEY domain_path (domain(140),path(51)) made by wp_upgrade, make_db_current_silent, dbDelta

    These appeared first around the 4.2 release, with different tables. I did not find a problem going from 4.0 to 4.2 or 4.4 but could not make the jump to 4.6, eventually whittled it down to 4.4.10 as the newest release I can get working.

    When I Upgrade Network on a 4.5 WP install, the site starts sending 500 errors to my dashboard. The apache logs contain the errors above, and every page load causes a seg fault like this:

    [Tue Aug 01 17:57:24.984745 2017] [core:notice] [pid 20564] AH00052: child pid 20568 exit signal Segmentation fault (11)

    I’ve tried a lot of different approaches to getting past 4.4.10, but nothing’s worked yet. I am fairly unfamiliar with Multisite, this is my first major update, so I may have made an error in a previous version. But, at 4.4.10 everything looks to be working very well.

    Any insight would be most welcome!

Viewing 6 replies - 1 through 6 (of 6 total)
  • To me it seems that the update got confused and is trying to alter your database tables to the current version; but they are already current. I’m not sure how to fix that.

    Recently I upgraded an outdated WP from 4.2.2 to 4.8. I didnt have any issues, luckily.

    My guess is your db_version option wasnt updated in one of your installations.

    Look at this page that describes db_version. You might try to update it to the version of your current WP – https://codex.wordpress.org/FAQ_Installation

    Thank you for the suggestions. The database versions are correct for the WP version I’m running. With WP 4.4.10, the version is 35700. When I upgrade to WP 4.5, the version changes to 36686. This happens automatically, no link to choose to update the DB appears on the dashboard.

    The admin dashboard becomes inaccessible when the 4.5 files are installed and the server is started. I reverted the db_version at this point to 35700 and restarted the server. The dashboard is still inaccessible so there is no way to manage anything once the files from 4.5 are installed.

    Are you disabling your plugins and mu-plugins during upgrades?

    What errors are you getting in the error logs when the 4.5 admin dashboard is broken?

    This db upgrade process appears to be flawed. It’s possible that some intermediate db update was skipped over, even though the 4.4.10 version seems to work flawlessly. I hate to have to go back and incrementally update through every version between 3.8 and 4.5 just to catch the change, but I have no clue how else to determine what is wrong.

    The errors still appear in the log with the duplicate key, and WP is apparently not able to determine that the actual structure of its database is not in compliance with the version it claims to be current on. That is, for 4.4.10 it’s supposed to be 35700 and for 4.5 it’s 36686. There must have been some folks who did this update when it first came out, and none of them experienced this issue if search results are any indication.

    Looking at the change log here: https://codex.wordpress.org/WordPress_Versions, I’m struck by the Release Date of 4.4.10:

    4.4.10 May 16, 2017 Changelog Blog 35700

    That is quite out of sync with the release schedule, and I wonder if there were changes in that release made after the fact. Otherwise, this could be a typo and the date should actually be 2016. Looking at the release notes, it seems they did release 4.4.10 in May 2017. What is up with that?

    This might be a way to get things working again, if I can use the actual release dates and pick and choose the versions I upgrade through, skipping those which came out-of-band with the schedule.

    Again, I thank you for your suggestions as this may have put me on a track to resolving the problem. I’ll update this post once I know more.

    No need to disable plugins after 2.x something, according to WP install docs. However, I did try this just in case; it didn’t make any difference.

    The error is that the site is completely inaccsssible. Not only the dashboard, but the public site as well. Every URL known to the site gives a page inaccessible error:

    This page isn’t working

    <site name> didn’t send any data.
    ERR_EMPTY_RESPONSE

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.