Support » Installing WordPress » Upgrade from WP version 1.0.1 ??

  • I have been running WP for many years now without ever touching it, but recently have been thinking about changing my website design and finally upgrading.

    I am still at version 1.0.1 !

    Is it even possible to upgrade?
    Can I use my same database / layout / etc.?
    Should I in fact upgrade?
    There is always the “if it aint broke dont fix it” saying.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes, you should definitely upgrade, though it’s likely that going from version 1.0.1 to 2.2.2 is going to pose some compatibility problems with any plugins you’re running, and quite probably with any themes you might be using.

    I don’t see any reason why upgrading should prove problematic. Just make sure you follow all the directions for upgrading, including deactivating all plugins before running the upgrade script, as active plugins are often the major thing that break an upgrade.

    It’s less about not being broke than it is about security, though of course, newer versions of WordPress are more powerful and user-friendly overall than older versions.

    mrmist

    (@mrmist)

    Forum Janitor

    I think from reading on here other people have had random issues happen when they have upgraded in large leaps. You may be better off either trying to get some of the intermediate releases and upgrading in stages, or, if possible, doing an export-completely new install-import.

    Does anyone know if the 1.0.1 database is even still compatible with WP version 2.2.2? Has there been any major database changes in the past years?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Upgrade from WP version 1.0.1 ??’ is closed to new replies.