[resolved] Upgrade from 3.1 to 3.2: Endless "Your WordPress database is already up-to-date" (19 posts)

  1. gboudreau
    Posted 5 years ago #

    I updated (automatically, then manually) to WordPress 3.2, from 3.1.4.
    Now, when I try to go in /wp-admin/, I get redirected to:
    which says:

    "No Update Required
    Your WordPress database is already up-to-date!"

    Clicking Continue sends me back to my blog's homepage, and trying to access wp-admin again does the same.

    Any idea how I can debug what's happening ?


    Blog URL: http://www.pommepause.com/blog/

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    - switching to the Twenty Ten theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

  3. Also flush your browser cache.

  4. gboudreau
    Posted 5 years ago #

    I excluded the possible browser cause by using curl:

    $ curl -i "http://www.pommepause.com/blog/wp-admin/index.php"
    HTTP/1.1 302 Found
    X-Powered-By: PHP/5.3.3
    Location: http://www.pommepause.com/blog/wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2Fwp-admin%2Findex.php

    I tried to rename my theme folder, but that didn't help.
    I tried to rename my plugins folder too, and that didn't help either.
    I'm always redirected to upgrade.php

  5. gboudreau
    Posted 5 years ago #

    I also tried emptying the active_plugins options in MySQL (to a:0:{}), and that didn't help either.
    I guess I'll debug the PHP code to find why it redirects, when it shouldn't (or why it thinks there's nothing to update when there is).
    I use another prefix that wp_ for my tables; maybe it's related.

  6. Are you also using MultiSite?

  7. gboudreau
    Posted 5 years ago #


    I found that in ./wp-admin/admin.php:42
    get_option('db_version') == 17516
    $wp_db_version == 18226

    But in ./wp-admin/upgrade.php:58, both get_option( 'db_version' ) and $wp_db_version == 18226

    I'll continue to investigate why get_option('db_version') in admin.php seems to be wrong... (MySQL options table where option_name = 'db_version' == 18226)

  8. Try re-applying the upgrade manually. You may have caught a bad download.

  9. gboudreau
    Posted 5 years ago #

    I already did. I did an automatic upgrade first, and when I noticed that issue, I manually downloaded the tgz from the website, and unpacked over.

    I now found that the values returned by wp_cache_get( 'alloptions', 'options' ) seems to be outdated.
    Not sure what should trigger the cache to become invalid, but that seems to have failed... Continuing debugging.

  10. gboudreau
    Posted 5 years ago #

    I'm pretty sure the problem comes from the memcached plugin I have installed...
    No idea why the problem would persist even with the plugins folder renamed though!

  11. gboudreau
    Posted 5 years ago #

    Ah, I see... Part of the memcached plugin install was to copy a file into ./wp-content/object-cache.php!
    Renaming this file to object-cache.php.bak fixed the issue.

    I guess I should contact that plugin's author, to tell him his cache wasn't properly reset when it should have been?

  12. gboudreau
    Posted 5 years ago #

    Also, a simple restart of the memcached process fixed this permanently, since that empty the memcache cache!

  13. Yeah, do let the plugin dev know :)

    Which one is this? I'm keeping a running list ;)

  14. gboudreau
    Posted 5 years ago #

    Plugin Name: Memcached
    Description: Memcached backend for the WP Object Cache.
    Version: 2.0
    Plugin URI: http://dev.wp-plugins.org/browser/memcached/
    Author: Ryan Boren
  15. You may want to upgrade to 2.0.1


  16. gboudreau
    Posted 5 years ago #

    Indeed. Just did when I noticed I was using an older version.
    Thanks for your time.

  17. dartiss
    Posted 5 years ago #

    My installation too also got stuck in the "your database is already up-to-date" loop.

    However, trying a different browser I could access my admin, so I cleared my browser cache and could then access it.


  18. Rafal Lukawiecki
    Posted 5 years ago #

    My installation got stuck in the same way. A full server reboot solved the problem. I am running W3 Total Cache with APC OpCode caching.

  19. Harsh Agrawal
    Posted 4 years ago #

    On my blog shoutmeloud.com
    I got stuck with similar situation after upgrading to WordPress 3.4.1
    I was using W3 total cache..
    I renamed the plugins folder to pllugins1
    And it fixed the issue..Later I changed the name back...

Topic Closed

This topic has been closed to new replies.

About this Topic