Support » Installing WordPress » Upgrade from 2.6.5 to 2.7 failing badly

  • Resolved jamesbe


    Hi there,

    I am trying to upgrade from 2.6.5 to 2.7.

    I have a live server and duplicate on a linux box at home. I attempted the upgrade following all the procedures on my home machine and it was flawless.

    On the live server not so good. The main page just keeps reloading…. well it doesn’t even load the address bar in my browser just loops over and over and you can tell it is reloading. I can get into the dashboard and everything seems perfectly fine but the site doesn’t work at all.

    I followed all the instructions to a T. Then I gave up and even took the upgraded database from my backup machine and entire wordpress directory and copied these to my live machine.

    That should have solved it as now the database and files are identical to a working machine but no that didn’t work either. Now I couldn’t get in the backend or frontend and instead of reloading every page just presents me with a tilda ~

    Any idea what could be going on here?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Just an update, I thought it might be wise to see if setting up a new 2.7 install on the server would work. Well it does so… that rules some type of compatibility out I would think….

    nevermind I fixed it. index.htm had a redirect but that never got hit with version 2.6.5

    Thanks for this, also fixed mine after an hour of tearing my hair out!

    I don’t understand why this is an issue though – going to /index.htm on my blog now gives a 404, when before it redirected (thanks to a 301 in my .htaccess) to /index.php.

    So, any links to index.htm now point to a 404 instead of my homepage. Is there any way round this?

    What exactly did you change?

    I have the same problem? Loading just loops for the front end then fails, although back end works fine.

    I removed the 301 redirect for index.htm to index.php – got it working, but now means going to /index.htm on my site gives a 404 instead of the homepage.

    My original site homepage was index.htm, so it was useful to have this 301 in place, but until someone tells me how to get around it, I have to live with the 404 (I guess I could create a custom error page for that…)

    This is an issue. I NEED my index.htm back! I guess I too can create an custom page but this is ridiculous it worked fine up to 2.6.5

    I’ll mark this as unresolved perhaps someone else in the know will see it.

    Hi there fellas.

    If you are having this problem still I have found a solution that works on my server.

    In the .htaccess I put the following line.

    RewriteRule ^index.htm$ [R=301,L]

    I put this before this:
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Upgrade from 2.6.5 to 2.7 failing badly’ is closed to new replies.