Support » Installing WordPress » Upgrade from 2.0 to 2.1 got stuck –

  • Resolved muesliq

    (@muesliq)


    I’m really really stuck – please HELP!

    I was upgrading my WP install using my hoster’s (dreamhost) “1-click-install”-feature. It is supposed to do the upgrade including backup automatically.

    Problems now:

    (1) All static pages are inaccessible (404), yet they have been converted to posts. See my site at helge.at.
    (2) Even image-uploads show up in the manage-posts section as posts..!
    (3) The dashboard footer still shows the old version number 2.0.4
    (4) When using the WP-backend (that still works) I’m send to upgrade.php every once in a while. It always ends with the success message.
    (5) There is supposed to be an automatic backup-folder (by 1-click-install) on my server, yet there isn’t.

    Details:
    – Upgrade was from 2.0.4 to 2.1.2
    – I have tried disabling wp-cache and rebuilding permalinks, in vain.

    Ps. I promise never to use the 1-click-install again!

Viewing 15 replies - 1 through 15 (of 21 total)
  • muesliq

    (@muesliq)

    To be more specific: This used to be a “page”: http://www.helge.at/wlan/ – now 404.

    Yet suddenly it has become a “post”: http://www.helge.at/2006/09/wlan/

    Chris_K

    (@handysolo)

    Your theme doesn’t appear to be 2.1 aware. I bet if you try the Default theme, your page will be fine?

    Have a look at this article: http://www.transycan.net/blogtest/2007/01/23/how-pages-are-different-in-wp-21/

    muesliq

    (@muesliq)

    Hi Handysolo, thanks for your reply!

    I just switched back to WordPress Default 1.5 (Kubrick) and my “page” still gives a 404.

    Also, note that my dashboard-footer still says “2.0.4”.

    Chris_K

    (@handysolo)

    Hmm, yeah. It would seem you didn’t get a complete upgrade.

    Does the DreamHost thing report the blog as being 2.1.2 now, or does it still indicate it needs to be upgraded? If you can, run it again.

    Otherwise … Upgrading_WordPress

    muesliq

    (@muesliq)

    The DH-tool reports it as being 2.1.2, yes. Will try the manual upgrade.

    Anything specific i’ll have to take care of given the above situation?

    Chris_K

    (@handysolo)

    Not really no. I’d just treat it like a normal upgrade.

    muesliq

    (@muesliq)

    OK, I upgraded from scratch. The dashboard now shows 2.1.2.

    BUT: The static pages are still 404, also with the default template.

    dark-raven

    (@dark-raven)

    This may not be a helpful solution as I’m kind of new to wordpress and still learning it but to me it may be a Permalink setting that is set differently from what it had been. I upgraded a friends site and it had changed the permalink settings to a different setting from what it had been.

    But again this may not be a solution. Its just a thought though. If its not just ignore this post.

    Mike

    muesliq

    (@muesliq)

    @dark-raven: Nope, that’s a different problem. In my case pages don’t work, posts do.

    @HandySolo: I have re-read the article you linked to above and tried to understand if my theme is concerned. I have full-text-searched it for post_status, yet no ocurrence.

    Also, I tried to re-create my pages with copy&paste content. This is what happened:
    – Before: 404.
    – Now: Showing the correct <title> but displaying the blog-index instead of the page content.

    What can I try next?

    muesliq

    (@muesliq)

    Further update:

    I searched my theme for deprecated templates and did indeed find one in page.php:

    <?php link_pages('<p><strong>Pages:</strong> ', '</p>', 'number'); ?>

    I tried to comment the whole line out (as I don’t use pagination in pages anyway) but the same problem persisted.

    On a sidenote: I hope I have made it clear that all my pages (but the one I created meanwhile, see above) have disappeared totally from the page manager – so I guess my DB must be in the state of the previous version..? Not sure.

    Chris_K

    (@handysolo)

    Well, something’s certainly amiss with the database.

    Do you have phpMyAdmin or something similar? Browse through the data in your wp_posts table (where wp_ is your prefix).

    Find one of the “old” Pages that is now showing up as a Post (you can probably search on the Post_Name column for it).

    Make sure that Post_Type is set to ‘page’ and Post_Status is ‘publish’. See if that helps?

    muesliq

    (@muesliq)

    I did as you said. Post_Status was ‘publish’, Post_Type was ‘post’. I set it to ‘page’ manually.

    Same change as the copy-paste action above:
    – Page now produces no 404 anymore.
    – Page shows correct <title> but incorrect content, shows main blog index instead of page content.

    Chris_K

    (@handysolo)

    I’m pretty much stumped. Maybe someone else will have a bright idea.

    Do you have a DB backup from before the upgrade? If so, I’d probably try restoring it and re-running the wp-admin/upgrade.php script.

    muesliq

    (@muesliq)

    I have asked my hoster for a copy. Unfortunately I haven’t backup’ed myself, as I was trusting the automatic script to do that..

    muesliq

    (@muesliq)

    Ah, another thing: What if I manually set all pages to Post_Type ‘page’? I would then “only” have to fix the theme problem.

    What do you think?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Upgrade from 2.0 to 2.1 got stuck –’ is closed to new replies.