Support » Plugin: WP Offload Media Lite for Amazon S3, DigitalOcean Spaces, and Google Cloud Storage » Upgrade from 2.3.2 to >= 2.4 runs out of memory

  • Resolved Ian Barnes

    (@ianbarnes)


    Hi,

    We’re attempting to upgrade the plugin from the current 2.3.2 version to anything greater than (or equal to actually) 2.4. This results in the site timing out and in the error-logs, I get a memory limit error. I’ve tried upping the memory limit, but to no avail.

    The error:
    Got error 'PHP message: PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php on line 182', referer: https://domain.com/wp-admin/network/plugins.php

    I am very sure its the plugin, I’ve tried removing it entirely and re-installing and get the same result, I’m guessing due to the number of existing files?

    Its a MU WordPress site, running WP version 5.5.3. EWWW Image Optimizer 5.8.2 (Latest).

    PHP version 7.3. Apache 2.4

    Any ideas as to what’s causing it?

    Thanks
    Ian

    • This topic was modified 5 months, 1 week ago by Ian Barnes.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Delicious Brains Inc.

    (@deliciousbrains)

    Any ideas as to what’s causing it?

    No idea I’m afraid, would require the kind of digging in that isn’t feasible here.

    I recommend trying with WP Offload Media Lite 2.5.1 as there were some important fixes in that version.

    If that doesn’t help, please snag yourself a license and contact us via the Support tab in the plugin or license entry in your account page on our site and we’ll dig in to the problem with you.

    -IJ

    paulinab

    (@paulinab)

    Ian, did you find the cause of the issue? We’re updating our website and have exactly the same problem right now 🙁 Tried updating to 2.5.1 directly from 2.3.2, everything blew up.
    It runs out of memory, and when given “enough”, it runs out of execution time.

    • This reply was modified 5 months ago by paulinab.
    Thread Starter Ian Barnes

    (@ianbarnes)

    @deliciousbrains Thanks for taking the time to reply – I’m seeing how I can budget to do this – very keen to get this resolved! And I have tried with 2.5.1, I tested through various versions to find where exactly the break started happening and it was in 2.4

    @paulinab – Nope, no joy as of yet… would be keen to hear what you found in addition…

    Thread Starter Ian Barnes

    (@ianbarnes)

    Just a quick note that this was resolved with the upgrade to Version 2.5.2, so must have been something else in the system conflicting that was patched in 2.5.2!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.