WordPress.org

Support

Support » Installation » upgrade from 1.2.2 to 1.5 beta 1

upgrade from 1.2.2 to 1.5 beta 1

  • I currently have 1.2.2 installed. It works. It’s placed in a ‘wp’-directory. Now I’ve uploaded 1.5 beta 1 to another directory (‘wordpress’). Will my current 1.2.2 installation of WordPress (in the ‘wp’-directory) work if I upgrade to 1.5 beta 1 (from the ‘wordpress’-directory) ?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator James Huff

    @macmanx

    Support Team Rep.

    It will work as long as you keep your files and databases separate.

    arkhanien, I don’t think that you can use a *single* database with wp 1.2 and wp 1.5. You will have to copy this database and upgrade the copy. Makes it quite difficult to keep the two versions in sync, so you better hurry to port your theme and settings to 1.5 😉

    To confirm, you CANNOT have 1.2.2 and 1.5b1 running on the same database.

    Even if you change your table prefix to something like “messy_” ? as opposed to “wp_” ?

    Well, that means that you have two separate sets of tables. You can do this, but the two versions are not sharing the same information. The new install with a distinct table prefix will be empty. I was under the impression that arkhanien wanted to be able to use the SAME tables for BOTH versions.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘upgrade from 1.2.2 to 1.5 beta 1’ is closed to new replies.